Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # dev - Re: 0.96.0


Copy link to this message
-
Re: 0.96.0
Elliott Clark 2012-10-01, 23:24
That last little bit of Metrics migration to Metrics2 (hbase-4050) should
probably go in so that we're not straddling the different versions.

On Mon, Oct 1, 2012 at 3:38 PM, Andrew Purtell <[EMAIL PROTECTED]> wrote:

> This depends on if the master changes that use ZK multi ops will go in as
> an option that can be toggled by config, or as a replacement?
>
> If you run secure clusters then 3.4.5 (with ZOOKEEPER-1550) is what you
> want to use regardless.
>
> On Tuesday, October 2, 2012, lars hofhansl wrote:
>
> > You mean as build time dependency, right? (Not sure now)
> >
> > I think we have said in the past it's not a runtime dependency.
> >
> > Yeah, what I was trying to say was to require ZK 3.4.4 to run HBase.
> > Maybe 0.96 is too early for that, because we probably do not want to file
> > more jiras against to remove now obsolete related code.
> >
> > -- Lars
> >
> >
> >
> > ----- Original Message -----
> > From: Stack <[EMAIL PROTECTED] <javascript:;>>
> > To: [EMAIL PROTECTED] <javascript:;>
> > Cc: lars hofhansl <[EMAIL PROTECTED] <javascript:;>>
> > Sent: Monday, October 1, 2012 3:19 PM
> > Subject: Re: 0.96.0
> >
> > On Mon, Oct 1, 2012 at 3:10 PM, Jonathan Hsieh <[EMAIL PROTECTED]
> <javascript:;>>
> > wrote:
> > > +1 for doing it now for 0.96.
> > >
> >
> > We already have 3.4.4 as dependency.
> >
> > But sounds like we are saying that when you upgrade your hbase to
> > 0.96, you need to also update your zk to 3.4.4 because hbase wants to
> > use 3.4 zk features?  Is that what we're saying?
> >
> > Good stuff,
> > St.Ack
> >
> >
>
> --
> Best regards,
>
>    - Andy
>
> Problems worthy of attack prove their worth by hitting back. - Piet Hein
> (via Tom White)
>