Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo >> mail # user >> Error BAD_CREDENTIALS


+
Tim Piety 2013-01-08, 15:28
Copy link to this message
-
Re: Error BAD_CREDENTIALS
Accumulo keeps an internal store of users. When you initialize it, you only
initialize the root user. You need to manually create additional ones via
the shell or APIs. When you run the shell, you can pass it -u to specify
the user to log in as, otherwise it defaults to the system user you are.
Since you ran it as root, the namespaces corresponded so it worked out.
Create a user for demo and use the correct password and it should all work
out fine.
On Tue, Jan 8, 2013 at 10:28 AM, Tim Piety <[EMAIL PROTECTED]> wrote:

> All,
>
> I am getting the following error when trying to connect from a Java
> client:
>
> org.apache.accumulo.core.client.AccumuloSecurityException: Error
> BAD_CREDENTIALS - Username or Password is Invalid
>     at
> org.apache.accumulo.core.client.impl.ServerClient.execute(ServerClient.java:73)
>     at
> org.apache.accumulo.core.client.impl.ConnectorImpl.<init>(ConnectorImpl.java:75)
>     at
> org.apache.accumulo.core.client.ZooKeeperInstance.getConnector(ZooKeeperInstance.java:218)
>     at
> org.apache.accumulo.core.client.ZooKeeperInstance.getConnector(ZooKeeperInstance.java:206)
>     at
> com.raytheon.accumulo.demo.AccumuloConnection.main(AccumuloConnection.java:19)
> Caused by: ThriftSecurityException(user:demo, code:BAD_CREDENTIALS)
>     at
> org.apache.accumulo.core.client.impl.thrift.ClientService$authenticateUser_result.read(ClientService.java:7755)
>     at
> org.apache.accumulo.core.client.impl.thrift.ClientService$Client.recv_authenticateUser(ClientService.java:415)
>
> I get the same error if I run the accumulo shell as the demo user. If I
> run the shell as root it all runs fine.
>
> do I need to change some permissions somewhere? I changed the hdfs
> /accumulo to be 777 and all the files to be 777 as well, but that did not
> change anything,
>
> I installed accumulo as root and initialized it as root.
>
> thanks in advance,
>
> Tim
>
>
>
>
+
Tim Piety 2013-01-08, 16:45
+
John Vines 2013-01-08, 16:56
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB