Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - Slow scan request with basic test ?


Copy link to this message
-
Re: Slow scan request with basic test ?
Simon Majou 2013-06-14, 15:10
Hi,

I am using the latest stable (0.94.8), I have a i3 laptop with a SSD.

I am doing the basic test of the documentation :
http://hbase.apache.org/book/quickstart.html#shell_exercises

hbase(main):003:0> create 'test', 'cf'
0 row(s) in 1.2200 seconds
hbase(main):003:0> list 'test'
..
1 row(s) in 0.0550 seconds
hbase(main):004:0> put 'test', 'row1', 'cf:a', 'value1'
0 row(s) in 0.0560 seconds
hbase(main):005:0> put 'test', 'row2', 'cf:b', 'value2'
0 row(s) in 0.0370 seconds
hbase(main):006:0> put 'test', 'row3', 'cf:c', 'value3'
0 row(s) in 0.0450 seconds
Here is what I got :

create 'test', 'cf'
create 'test', 'cf'
0 row(s) in 9.1360 seconds

list 'test'
list 'test'
TABLE
test
1 row(s) in 0.0280 seconds

put 'test', 'row1', 'cf:a', 'value1'
put 'test', 'row1', 'cf:a', 'value1'
0 row(s) in 4.6200 seconds

put 'test', 'row2', 'cf:b', 'value2'
put 'test', 'row2', 'cf:b', 'value2'
0 row(s) in 0.0080 seconds

put 'test', 'row3', 'cf:c', 'value3'
put 'test', 'row3', 'cf:c', 'value3'
0 row(s) in 0.0060 seconds

scan 'test'
scan 'test'
ROW  COLUMN+CELL
 row1 column=cf:a, timestamp=1371222264939, value=value1
 row2 column=cf:b, timestamp=1371222269032, value=value2
 row3 column=cf:c, timestamp=1371222275823, value=value3
3 row(s) in 4.5920 seconds
It seems to have some ~4.5s latency, appearing 2x when creating a table,
and appearing on the first put and on scans.

Simon
Simon
On Fri, Jun 14, 2013 at 5:07 PM, Jean-Marc Spaggiari <
[EMAIL PROTECTED]> wrote:

> Hi Simon,
>
> Can you please provide more details? Which version are you testing
> with, what is the test you are doing, on what kind of computer this is
> running?
>
> Thanks,
>
> JM
>
> 2013/6/14 Simon Majou <[EMAIL PROTECTED]>:
> > Hello,
> >
> > When doing the basic test after installing, the scan request is really
> slow
> > (~5sec). There are no errors in the logs. Is it normal ? Why it is so ?
> >
> > Simon
>