Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Hive >> mail # user >> Re: hive-site.xml not found on classpath


+
Stephen Boesch 2012-11-29, 08:56
+
Shreepadma Venugopalan 2012-11-29, 20:42
+
Stephen Boesch 2012-11-29, 20:46
+
kulkarni.swarnim@...) 2012-11-29, 20:54
+
Stephen Boesch 2012-11-29, 21:02
Copy link to this message
-
Re: hive-site.xml not found on classpath
Hi, Stephen
what did you mean the "wrong place under /tmp" in
"I am seeing the following message in the logs (which are in the wrong
place under /tmp..)" ?

Did you mean that you set a different log dir but it didn't work?

the log dir should be set in conf/hive-log4j.properties,
conf/hive-exec-log4j.properties
and you can try to reset HIVE_CONF_DIR in conf/hive-env.sh with ‘export"
command.

- Bing

2012/11/30 Stephen Boesch <[EMAIL PROTECTED]>

> thought i mentioned in the posts those were already set and verified.. but
> yes in any case that's first thing looked at.
>
> steve@mithril:~$ echo $HIVE_CONF_DIR
> /shared/hive/conf
> steve@mithril:~$ echo $HIVE_HOME
> /shared/hive
>
>
> 2012/11/29 [EMAIL PROTECTED] <[EMAIL PROTECTED]>
>
> Have you tried setting HIVE_HOME and HIVE_CONF_DIR?
>>
>>
>> On Thu, Nov 29, 2012 at 2:46 PM, Stephen Boesch <[EMAIL PROTECTED]>wrote:
>>
>>> Yes.
>>>
>>>
>>> 2012/11/29 Shreepadma Venugopalan <[EMAIL PROTECTED]>
>>>
>>>> Are you seeing this message when your bring up the standalone hive cli
>>>> by running 'hive'?
>>>>
>>>>
>>>> On Thu, Nov 29, 2012 at 12:56 AM, Stephen Boesch <[EMAIL PROTECTED]>wrote:
>>>>
>>>>> i am running under user steve.  the latest log (where this shows up )
>>>>> is  /tmp/steve/hive.log
>>>>>
>>>>>
>>>>> 2012/11/29 Viral Bajaria <[EMAIL PROTECTED]>
>>>>>
>>>>>> You are seeing this error when you run the hive cli or in the
>>>>>> tasktracker logs when you run a query ?
>>>>>>
>>>>>> On Thu, Nov 29, 2012 at 12:42 AM, Stephen Boesch <[EMAIL PROTECTED]>wrote:
>>>>>>
>>>>>>>
>>>>>>> I am seeing the following message in the logs (which are in the
>>>>>>> wrong place under /tmp..)
>>>>>>>
>>>>>>>  hive-site.xml not found on classpath
>>>>>>>
>>>>>>> My hive-site.xml is under the standard location  $HIVE_HOME/conf so
>>>>>>> this should not happen.
>>>>>>>
>>>>>>> Now some posts have talked that the HADOOP_CLASSPATH was mangled.
>>>>>>>  Mine is not..
>>>>>>>
>>>>>>> So what is the underlying issue here?
>>>>>>>
>>>>>>> Thanks
>>>>>>>
>>>>>>> stephenb
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>>
>> --
>> Swarnim
>>
>
>
+
Stephen Boesch 2012-11-30, 07:05
+
Bing Li 2012-11-30, 08:01
+
Stephen Boesch 2012-11-30, 08:15
+
Lauren Yang 2012-11-30, 18:46
+
Stephen Boesch 2012-12-09, 08:06
+
Stephen Boesch 2012-12-09, 20:32
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB