Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # user >> Multinode cluster only recognizes 1 node


Copy link to this message
-
Re: Multinode cluster only recognizes 1 node
Sean 

Can you paste the name node and jobtracker logs.

It could be something as simple as disabling the firewall.

Raj

>________________________________
> From: "Barry, Sean F" <[EMAIL PROTECTED]>
>To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
>Sent: Tuesday, July 31, 2012 1:23 PM
>Subject: RE: Multinode cluster only recognizes 1 node
>
>After a good number of hours trying to tinker with my set up I am still am only seeing results for 1, not 2 nodes.
>
>This is the tut I followed
>http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux-multi-node-cluster/
>
>After executing ./start-all.sh
>
>starting namenode, logging to /usr/local/hadoop/logs/hadoop-hduser-namenode-master.out
>slave: starting datanode, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-datanode-slave.out
>master: starting datanode, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-datanode-master.out
>master: starting secondarynamenode, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-secondarynamenode-master.out
>starting jobtracker, logging to /usr/local/hadoop/logs/hadoop-hduser-jobtracker-master.out
>slave: starting tasktracker, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-tasktracker-slave.out
>master: starting tasktracker, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-tasktracker-master.out
>
>
>
>
>
>-----Original Message-----
>From: syed kather [mailto:[EMAIL PROTECTED]]
>Sent: Thursday, July 26, 2012 6:06 PM
>To: [EMAIL PROTECTED]
>Subject: Re: Multinode cluster only recognizes 1 node
>
>Can you paste the information when you execute . start-all.sh in kernal..
>when you do ssh on slave .. whether it is working fine...
>On Jul 27, 2012 4:50 AM, "Barry, Sean F" <[EMAIL PROTECTED]> wrote:
>
>> Hi,
>>
>> I just set up a 2 node POC cluster and I am currently having an issue
>> with it. I ran a wordcount MR test on my cluster to see if it was
>> working and noticed that the Web ui at localhost:50030 showed that I
>> only have 1 live node. I followed the tutorial step by step and I
>> cannot seem to figure out my problem. When I ran start-all.sh all of
>> the daemons on my master node and my slave node start up perfectly
>> fine. If you have any suggestions please let me know.
>>
>> -Sean
>>
>
>
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB