Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Flume >> mail # user >> Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1


+
shouvanik.haldar@... 2012-12-10, 06:04
+
shouvanik.haldar@... 2012-12-10, 06:10
+
Nitin Pawar 2012-12-10, 07:22
+
shouvanik.haldar@... 2012-12-10, 08:17
+
Nitin Pawar 2012-12-10, 09:13
+
shouvanik.haldar@... 2012-12-10, 09:31
+
Nitin Pawar 2012-12-10, 10:03
+
shouvanik.haldar@... 2012-12-11, 07:14
+
Nitin Pawar 2012-12-11, 07:24
+
shouvanik.haldar@... 2012-12-11, 07:27
+
Alexander Alten-Lorenz 2012-12-11, 07:33
+
shouvanik.haldar@... 2012-12-11, 08:11
+
Brock Noland 2012-12-10, 12:42
Copy link to this message
-
RE: Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1
The previous error is now resolved. Actually some jars were missing which flume requires. Some errors are still there..I will let you know in a short while.

Thanks and Regards,
Shouvanik Haldar | Cloud SME Pool | Mobile:+91-9830017568
-----Original Message-----
From: Haldar, Shouvanik
Sent: Tuesday, December 11, 2012 1:42 PM
To: [EMAIL PROTECTED]; [EMAIL PROTECTED]
Subject: RE: Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1

Hi,

This error is removed. I copied flume-node as flume-master, replace all "node" with "master" and thus it worked! Thanks

Now, I am facing a new weird error. I had mentioned source and sink. Now, Flume node status is set to "OPENING" and nothing else is happening even I do a refresh.

In the flume-master console, I executed the below mentioned commands at the "Configure multiple nodes" textarea!

Please help me. Which logs should I check!

Commands at "Configure multiple nodes" textarea
---------------------------------------------------
ec2-75-101-165-36.compute-1.amazonaws.com:tail("/var/log/flume/test1.log")|agentBESink("ec2-75-101-165-36.compute-1.amazonaws.com",35853);
ec2-75-101-165-36.compute-1.amazonaws.com:collectorSource(35853)|EHCacheSink("Y","/var/log/flume");

When I tail the log at "/var/log/flume/flume-flume-node-ip-10-40-222-77.log", the logs don't move after

"2012-12-11 02:59:48,598 INFO com.cloudera.flume.conf.SinkFactoryImpl: Found sink decorator EHCacheDecorator in com.EHCacheDecorator
2012-12-11 02:59:48,644 INFO com.cloudera.flume.agent.LogicalNode: Node config successfully set to FlumeConfigData: {srcVer:'Wed Dec 31 19:00:00 EST 1969' snkVer:'Wed Dec 31 19:00:00 EST 1969'  ts='Wed Dec 31 19:00:00 EST 1969' flowId:'null' source:'null' sink:'null' }
2012-12-11 02:59:48,771 INFO com.cloudera.flume.agent.FlumeNode: Hadoop Security enabled: false
2012-12-11 02:59:53,484 INFO com.EHCacheSink: EHCacheSink: setting EHCache Debug=Y debugfilePath=/var/log/flume
2012-12-11 02:59:53,486 INFO com.cloudera.flume.collector.CollectorSource: opened
2012-12-11 02:59:53,486 INFO com.cloudera.flume.agent.LogicalNode: Node config successfully set to FlumeConfigData: {srcVer:'Tue Dec 11 02:55:27 EST 2012' snkVer:'Tue Dec 11 02:55:27 EST 2012'  ts='Tue Dec 11 02:55:27 EST 2012' flowId:'default-flow' source:'collectorSource( 35853 )' sink:'EHCacheSink( "Y", "/var/log/flume" )' }
2012-12-11 02:59:53,498 INFO com.cloudera.flume.handlers.thrift.ThriftEventSource: Starting blocking thread pool server on port 35853..."
When I do a "netstat -nlp| grep 35853"
I get
"[root@ip-10-40-222-77 bin]# netstat -nlp| grep 35853
tcp        0      0 :::35853                    :::*                        LISTEN      21096/java

"

Please help!

Thanks and Regards,
Shouvanik Haldar | Cloud SME Pool | Mobile:+91-9830017568

-----Original Message-----
From: Alexander Alten-Lorenz [mailto:[EMAIL PROTECTED]]
Sent: Tuesday, December 11, 2012 1:03 PM
To: [EMAIL PROTECTED]
Cc: [EMAIL PROTECTED]
Subject: Re: Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1

Hi,

yum remove --force <paketname>

Or simply create a empty file called /etc/init.d/flume-master:

echo "foo" > /etc/init.d/flume-master

best
- Alex

On Dec 11, 2012, at 8:27 AM, [EMAIL PROTECTED] wrote:

> Hi,
>
> Can you please help me on one thing! Mistakenly deleted /etc/init.d/flume-master script. Now flume-master is not getting uninstalled or removed! Please help!
>
> Thanks and Regards,
> Shouvanik Haldar | Cloud SME Pool | Mobile:+91-9830017568
>
> From: Nitin Pawar [mailto:[EMAIL PROTECTED]]
> Sent: Tuesday, December 11, 2012 12:55 PM
> To: Haldar, Shouvanik
> Cc: [EMAIL PROTECTED]
> Subject: Re: Getting weird error -> 2012-12-10 01:01:42,190 INFO com.cloudera.flume.watchdog.Watchdog: Subprocess exited with value 1
>
> there is no master/slave architecture now
>

Alexander Alten-Lorenz
http://mapredit.blogspot.com
German Hadoop LinkedIn Group: http://goo.gl/N8pCF
+
shouvanik.haldar@... 2012-12-11, 12:43
+
shouvanik.haldar@... 2012-12-11, 12:45
+
Alexander Alten-Lorenz 2012-12-11, 13:40
+
shouvanik.haldar@... 2012-12-11, 13:48
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB