Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - HBase is not running.


Copy link to this message
-
Re: HBase is not running.
Yves S. Garret 2013-05-28, 17:08
Ok, it's obvious that this is a networking issue.  I'm running on CentOS
and the hostname file is not in /etc, it's located in /etc/sysconfig/network
instead.

This is how that file looks like at the moment:
NETWORKING=yes
HOSTNAME=ysg.connect

/etc/hosts is like this:
127.0.0.1   localhost   ysg.connect
On Tue, May 28, 2013 at 1:05 PM, Yves S. Garret
<[EMAIL PROTECTED]>wrote:

> Just curious, but what's zookeeper.sh in the bin directory of HBase?
>
>
> On Fri, May 24, 2013 at 10:27 PM, Jay Vyas <[EMAIL PROTECTED]> wrote:
>
>> Yes that's a great post it helped me appreciate the complexity of the
>> whole thing to. There's gotta be a JIRA in here somewhere :)
>>
>> Sent from my iPhone
>>
>> On May 24, 2013, at 7:08 PM, "Yves S. Garret" <[EMAIL PROTECTED]>
>> wrote:
>>
>> > I do want to know.  Maybe that'll get my problem resolved.
>> >
>> >
>> > On Fri, May 24, 2013 at 5:00 PM, Asaf Mesika <[EMAIL PROTECTED]>
>> wrote:
>> >
>> >> If you truly want to understand the weirdness behind what you
>> witnessed,
>> >> then make a big cup of coffee, prepare a notebook with a pen and sit
>> down
>> >> to read this:
>> http://blog.devving.com/why-does-hbase-care-about-etchosts/
>> >> My friend at devving.com had a fight like this with HBase pseudo
>> mode, but
>> >> decided to go really deep into HBase code , JVM, Dns resolving and
>> Linux
>> >> standards.
>> >>
>> >>
>> >> On Friday, May 24, 2013, Jay Vyas wrote:
>> >>
>> >>> +1 for a VM on your own machine.  That's how I do it because its easy
>> to
>> >>> control and muck with network settings .
>> >>>
>> >>> Cant you just Edit etc/hostname file ?
>> >>>
>> >>> On May 24, 2013, at 4:03 PM, Jean-Daniel Cryans <[EMAIL PROTECTED]>
>> >>> wrote:
>> >>>
>> >>>> This is a machine identity problem. HBase simply uses the normal Java
>> >>>> APIs and asks "who am I?". The answer it gets is
>> >>>> ip72-215-225-9.at.at.cox.net. Changing this should only be a matter
>> of
>> >>>> DNS configs, starting with /etc/hosts. What is your machine's
>> hostname
>> >>>> exactly (run "hostname")? When you ping it, what does it return? That
>> >>>> should get you started. Does you machine even have a local IP when
>> you
>> >>>> run ifconfig? If not, all you can do is force everything to localhost
>> >>>> in your network configs. It also means you cannot use HBase in a
>> >>>> distributed fashion.
>> >>>>
>> >>>> Changing the code seems like a waste of time, HBase is inherently
>> >>>> distributed and it relies on machines having their network correctly
>> >>>> configured. Your time might be better spent using a VM on your own
>> >>>> machine.
>> >>>>
>> >>>> J-D
>> >>>>
>> >>>> On Fri, May 24, 2013 at 12:38 PM, Yves S. Garret
>> >>>> <[EMAIL PROTECTED]> wrote:
>> >>>>> That seems to be the case.  The thing that I don't get is if I
>> missed
>> >>> any
>> >>>>> "global" setting in order to make everything turn towards localhost.
>> >>> What
>> >>>>> am I missing?
>> >>>>>
>> >>>>> I'll scour the HBase docs again.
>> >>>>>
>> >>>>>
>> >>>>> On Fri, May 24, 2013 at 1:17 PM, Jay Vyas <[EMAIL PROTECTED]>
>> >> wrote:
>> >>>>>
>> >>>>>> Yes ... get hostname and /etc/hosts synced up properly and i bet
>> that
>> >>> will
>> >>>>>> fix it
>> >>>>>>
>> >>>>>>
>> >>>>>> On Fri, May 24, 2013 at 12:41 PM, Jean-Daniel Cryans <
>> >>> [EMAIL PROTECTED]
>> >>>>>>> wrote:
>> >>>>>>
>> >>>>>>> Ah yeah the master advertised itself as:
>> >>>>>>>
>> >>>>>>> Attempting connect to Master server at
>> >>>>>>> ip72-215-225-9.at.at.cox.net,46122,1369408257140
>> >>>>>>>
>> >>>>>>> So the region server cannot find it since that's the public
>> address
>> >>>>>>> and nothing's reachable through that. Now you really need to fix
>> >> your
>> >>>>>>> networking :)
>> >>>>>>>
>> >>>>>>> J-D
>> >>>>>>>
>> >>>>>>> On Fri, May 24, 2013 at 8:21 AM, Yves S. Garret
>> >>>>>>> <[EMAIL PROTECTED]> wrote:
>> >>>>>>>> Ok, weird, it still seems to be looking towards Cox.
>> >>>>>>>>
>> >>>>>>>> Here is my hbase-site.xml file: