Hi, XiaoChuan,

Just confirmed with Jiangjie Qin (our in-house Kafka PMC), Kafka client
0.10.1.1 does not work with broker 0.10.0 due to new protocol version
introduced in 0.10.1.1. Hence, if you try to run Samza 0.13.1 against Kafka
broker 0.10.0 version, it won't work. The best option for that seems to be
swapping out the runtime Kafka client 0.10.1.1 version in Samza 0.13.1 to
Kafka client 0.10.0.1 (which was used in Samza 0.12). Since there is no
incompatible API calls to Kafka client lib between Samza 0.12.0 and Samza
0.13.1, that should work and is worth trying out.

Let us know if we can be further assistance here.

Thanks!

-Yi

On Thu, Aug 31, 2017 at 4:14 PM, Yi Pan <[EMAIL PROTECTED]> wrote:
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB