Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> hbase/.archive doesn't exist


Copy link to this message
-
Re: hbase/.archive doesn't exist
HBASE-8195 has been opened.

But I don't think this is related to the issue Jian is facing ;)

2013/3/25 Ted Yu <[EMAIL PROTECTED]>:
> I agree.
>
> Log a JIRA ?
>
> On Mon, Mar 25, 2013 at 6:25 PM, Jean-Marc Spaggiari <
> [EMAIL PROTECTED]> wrote:
>
>> I think this should be removed from there since it has been removed
>> from the code.
>>
>> 2013/3/25 Ted Yu <[EMAIL PROTECTED]>:
>> > I found the entry in src/main/resources/hbase-default.xml of 0.94 branch.
>> >
>> > On Mon, Mar 25, 2013 at 6:06 PM, Jean-Marc Spaggiari <
>> > [EMAIL PROTECTED]> wrote:
>> >
>> >> It's not even in 0.95 neither in trunk...
>> >>
>> >> It was supposed to be added by HBASE-5547...
>> >>
>> >> But now, it's hardcoded.
>> >>
>> >> In HConstant, you have public static final String
>> >> HFILE_ARCHIVE_DIRECTORY = ".archive"; and it's used in
>> >> HFileArchiveUtil. 5547 was supposed to make that configurable by
>> >> reading this property in the config with a default value as
>> >> ".archive".
>> >>
>> >> If  you look in 0.95 history, you can see that it has been succesfuly
>> >> applied.
>> >>
>> >> Then this has been removed by HBASE 6439.
>> >>
>> >> Ted, where have you found this config extract? Is it from the
>> >> documentation? Because it's not used any more. I think this should be
>> >> cleaned.
>> >>
>> >> Jian, have you recently updated from an older HBase version?
>> >>
>> >> JM
>> >>
>> >> 2013/3/25 Ted Yu <[EMAIL PROTECTED]>:
>> >> > Do you use table archiving / snapshotting ?
>> >> > If not, the following DEBUG output should not be a concern.
>> >> >
>> >> > On a related note, I was searching for where the following config is
>> used
>> >> > in 0.94 source code but was unable to find any:
>> >> >
>> >> >   <property>
>> >> >     <name>hbase.table.archive.directory</name>
>> >> >     <value>.archive</value>
>> >> >     <description>Per-table directory name under which to backup files
>> >> for a
>> >> >       table. Files are moved to the same directories as they would be
>> >> under
>> >> > the
>> >> >       table directory, but instead are just one level lower (under
>> >> >       table/.archive/... rather than table/...). Currently only
>> applies
>> >> to
>> >> > HFiles.</description>
>> >> >   </property>
>> >> >
>> >> > 94-hbase tyu$ find . -name '*.java' -exec grep
>> >> > "hbase.table.archive.directory" {} \; -print
>> >> >
>> >> > On Mon, Mar 25, 2013 at 12:44 PM, Jian Fang
>> >> > <[EMAIL PROTECTED]>wrote:
>> >> >
>> >> >> Hi,
>> >> >>
>> >> >> I am running HBase 0.94.6 with Hadoop 2.0.2-alpha. The log keeps
>> >> printing
>> >> >> the following message:
>> >> >>
>> >> >> 2013-03-25 19:32:15,469 DEBUG
>> >> >> org.apache.hadoop.hbase.master.CatalogJanitor: Scanned 1 catalog
>> row(s)
>> >> and
>> >> >> gc'd 0 unreferenced parent region(s)
>> >> >> 2013-03-25 19:33:05,683 DEBUG org.apache.hadoop.hbase.util.FSUtils:
>> >> hdfs://
>> >> >> 10.2.42.55:9000/hbase/.archive doesn't exist
>> >> >> 2013-03-25 19:34:05,682 DEBUG org.apache.hadoop.hbase.util.FSUtils:
>> >> hdfs://
>> >> >> 10.2.42.55:9000/hbase/.archive doesn't exist
>> >> >>
>> >> >> Is there anything wrong here?
>> >> >>
>> >> >> Thanks,
>> >> >>
>> >> >> Jian
>> >> >>
>> >>
>>