Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper >> mail # dev >> zookeeper pull request: Fixed package-script for chown-error


Copy link to this message
-
Re: zookeeper pull request: Fixed package-script for chown-error
Hi Junji,

Thank you for the patch. We currently don't accept github pull
requests. Please follow the steps described here:

http://wiki.apache.org/hadoop/ZooKeeper/HowToContribute

You could still use git for your development, and generate svn
compatible patches with "git diff --no-prefix".

As for the actual pull request, I think we stopped maintaining these
package files in favor of using BigTop. We should probably remove
these files.

--Michi

On Sun, Apr 7, 2013 at 8:09 PM, junjihashimoto <[EMAIL PROTECTED]> wrote:
> GitHub user junjihashimoto opened a pull request:
>
>     https://github.com/apache/zookeeper/pull/4
>
>     Fixed package-script for chown-error
>
>     When the package is installed, dpkg outputs "chown: invalid user: `zookeeper:hadoop'".
>     So fixed debian-package's install script(postrm and preinst).
>
>
>
> You can merge this pull request into a Git repository by running:
>
>     $ git pull https://github.com/junjihashimoto/zookeeper feature/package
>
> Alternatively you can review and apply these changes as the patch at:
>
>     https://github.com/apache/zookeeper/pull/4.patch
>
> ----
> commit 412747d143d2941f3711ca5e465f29c1e22b3540
> Author: Junji Hashimoto <[EMAIL PROTECTED]>
> Date:   2013-04-08T02:59:09Z
>
>     Fixed package-script for chown-error
>
> ----
>