Do you see any errors in the usersync logs? Is ranger https enabled? If so, are the certs in place properly? Do you see any errors in xa_portal.log?

From: Anandha L Ranganathan <[EMAIL PROTECTED]>
Reply-To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
Date: Monday, December 18, 2017 at 12:28 PM
To: "[EMAIL PROTECTED]" <[EMAIL PROTECTED]>
Subject: Re: LDAP integration, the users and groups are not populating in ranger admin tool

Thanks Sailaja for the reply.

I followed the instruction and able to establish the connection with LDAP and can retrieve all the groups and users. But I am unable to see user and group information on the ranger admin.
I am not sure what other configuration I am missing?  The document provides the config information for "Ranger User Info".  Is there any config changes required on the Advanced tab ?

Thanks in advance.
On Tue, Dec 12, 2017 at 10:07 AM, Sailaja Polavarapu <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>> wrote:
Hi Anand,
Looks like some config issue. It will be more helpful to figure out the issue if you can share your config and/or complete usersync logs. For reference, you can check this post on configuration for some common use cases.

https://community.hortonworks.com/articles/105620/configuring-ranger-usersync-with-adldap-for-a-comm.html

Thanks,
Sailaja.

From: Anandha L Ranganathan <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>>
Reply-To: "[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>" <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>>
Date: Monday, December 11, 2017 at 5:45 PM
To: "[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>" <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>>
Subject: LDAP integration, the users and groups are not populating in ranger admin tool

Hi
I am trying to integrate Ranger with LDAP. I made all the configuration and connectivity is established wtih LDAP. I was going through the logs and I can see syncing

12 Dec 2017 00:19:50  INFO LdapDeltaUserGroupBuilder [UnixUserSyncThread] - LdapDeltaUserGroupBuilder updateSink started
12 Dec 2017 00:19:50  INFO LdapDeltaUserGroupBuilder [UnixUserSyncThread] - Performing Group search first
12 Dec 2017 00:19:50  INFO LdapDeltaUserGroupBuilder [UnixUserSyncThread] - extendedAllGroupsSearchFilter = (&(objectclass=organizationalUnit)(|(uSNChanged>=0)(modifyTimestamp>=19700101120000Z)))
12 Dec 2017 00:19:50  INFO LdapDeltaUserGroupBuilder [UnixUserSyncThread] - cn empty for entry OU=GDUsers,DC=glassdoor,DC=local, skipping sync
12 Dec 2017 00:19:50  INFO LdapDeltaUserGroupBuilder [UnixUserSyncThread] - cn empty for entry OU=Service Accounts,OU=GDUsers,DC=glassdoor,DC=local, skipping sync
12 Dec 2017 00:19:50  INFO LdapDeltaUserGroupBuilder [UnixUserSyncThread] - cn empty for entry OU=ENGINEERING,OU=GDUsers,DC=glassdoor,DC=local, skipping sync
But I don't see this data being populated on the user tab on the ranger admin tool.  Is that I am missing something in the config ?
Thanks
Anand
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB