Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop, mail # dev - test patch fails with -1 findbugs


Copy link to this message
-
Re: test patch fails with -1 findbugs
Ted Yu 2013-05-12, 04:17
Here was the command I used (on MacBook):
ant test-patch -Dpatch.file=../ted-1.0.txt
-Dfindbugs.home=/Users/tyu/findbugs-2.0.2
-Dforrest.home=/Users/tyu/apache-forrest-0.9

But I didn't get very far:
     [exec] BUILD FAILED
     [exec] /Users/tyu/apache-forrest-0.9/main/forrest.build.xml:54:
/Users/tyu/apache-forrest-0.9/lib/core does not exist.

I didn't get missing class error, though.

Cheers

On Sat, May 11, 2013 at 3:04 PM, Amit Sela <[EMAIL PROTECTED]> wrote:

> Following Ted Yu's advice, I created an empty patch and got the same
> results... any ideas ?
> I do notice findbugs complaining of missing classes:
>
>   [exec]  [findbugs] The following classes needed for analysis were
> missing:
>      [exec]  [findbugs]   org.apache.tools.ant.Task
>      [exec]  [findbugs]   org.apache.tools.ant.BuildException
>      [exec]  [findbugs]   org.apache.tools.ant.types.FileSet
>      [exec]  [findbugs]   org.apache.tools.ant.Project
>      [exec]  [findbugs]   org.apache.tools.ant.DirectoryScanner
>      [exec]  [findbugs] Warnings generated: 638
>      [exec]  [findbugs] Missing classes: 6
>      [exec]  [findbugs] Calculating exit code...
>      [exec]  [findbugs] Setting 'missing class' flag (2)
>      [exec]  [findbugs] Setting 'bugs found' flag (1)
>      [exec]  [findbugs] Exit code set to: 3
>      [exec]  [findbugs] Classes needed for analysis were missing
>      [exec]  [findbugs] Output saved to
>
> /home/amits/Dev/hadoop-working-branch/hadoop-common-1/build/test/findbugs/hadoop-findbugs-report.xml
>      [exec]      [xslt] Processing
>
> /home/amits/Dev/hadoop-working-branch/hadoop-common-1/build/test/findbugs/hadoop-findbugs-report.xml
> to
>
> /home/amits/Dev/hadoop-working-branch/hadoop-common-1/build/test/findbugs/hadoop-findbugs-report.html
>      [exec]      [xslt] Loading stylesheet
> /usr/local/findbugs-1.3.9/src/xsl/default.xsl
>      [exec]  [findbugs] Java Result: 3
>
>
>
> On Sat, May 11, 2013 at 11:44 PM, Ted Yu <[EMAIL PROTECTED]> wrote:
>
> > As validation step, you can run an empty patch (adding whitespace in any
> > file) through test-patch.
> > You would have base number of findbugs warnings.
> >
> > Cheers
> >
> > On Sat, May 11, 2013 at 12:24 PM, Amit Sela <[EMAIL PROTECTED]> wrote:
> >
> > > Hi all,
> > >
> > > I've recently added a patch to branch-1 and I wanted to run test-patch.
> > > I run: ant test-patch -Dpatch.file=../HADOOP-6103-branch-1.patch
> > > -Dfindbugs.home=/usr/local/findbugs-1.3.9
> > > -Dforrest.home=/usr/local/apache-forrest-0.9
> > >
> > > and I get:
> > >
> > > BUILD SUCCESSFUL
> > >      [exec] Total time: 3 minutes 16 seconds
> > >      [exec]
> > >      [exec]
> > >      [exec]
> > >      [exec]
> > >      [exec] -1 overall.
> > >      [exec]
> > >      [exec]     +1 @author.  The patch does not contain any @author
> tags.
> > >      [exec]
> > >      [exec]     -1 tests included.  The patch doesn't appear to include
> > any
> > > new or modified tests.
> > >      [exec]                         Please justify why no tests are
> > needed
> > > for this patch.
> > >      [exec]
> > >      [exec]     +1 javadoc.  The javadoc tool did not generate any
> > warning
> > > messages.
> > >      [exec]
> > >      [exec]     +1 javac.  The applied patch does not increase the
> total
> > > number of javac compiler warnings.
> > >      [exec]
> > >      [exec]     -1 findbugs.  The patch appears to introduce 427 new
> > > Findbugs (version 1.3.9) warnings.
> > >
> > > But I can't seem to understand why findbugs fails (I have a hard
> > > time believing that my patch caused it).
> > >
> > > I'd really appreciate your help on this one,
> > >
> > > Thanks,
> > > Amit.
> > >
> >
>