Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # user >> Issue while using hive 0.9


Copy link to this message
-
Re: Issue while using hive 0.9
That won't work. You must use the exact same version which was used while
compiling Hive, i.e., 3.0.1 any other version won't work. Look at the
 classpath of java process of Hive to make sure there is no other version
in your classpath.

Hope it helps,
Ashutosh
On Mon, Sep 17, 2012 at 4:40 AM, Sarath <
[EMAIL PROTECTED]> wrote:

>  From ANTLR site downloaded the latest JAR -> antlr-3.4-complete.jar.
> Copied this to lib folder and tried again. Same issue persists.
>
> Thanks,
> Sarath.
>
>
> On Monday 17 September 2012 04:42 PM, Joshi, Rekha wrote:
>
> Try with antlr 3.4.1 jar?
>
>  Thanks
> Rekha
>
>   From: Sarath <[EMAIL PROTECTED]>
> Reply-To: <[EMAIL PROTECTED]>
> Date: Mon, 17 Sep 2012 16:24:02 +0530
> To: <[EMAIL PROTECTED]>
> Subject: Issue while using hive 0.9
>
>  Hi,
>
> I'm new to hive.
>
> As first step downloaded version 0.9 and upacked it. Set the HIVE_HOME to
> the unpacked folder.
> I already have hadoop 1.0.3 installed and its configuration is in
> classpath.
>
> Then issued the hive command and got the hive prompt. After this whatever
> I try to execute, results in the below error -
> *Exception in thread "main" java.lang.NoSuchFieldError: type
>     at
> org.apache.hadoop.hive.ql.parse.HiveLexer.mKW_CREATE(HiveLexer.java:1602)
>     at
> org.apache.hadoop.hive.ql.parse.HiveLexer.mTokens(HiveLexer.java:6380)
>     at org.antlr.runtime.Lexer.nextToken(Lexer.java:89)
>     at
> org.antlr.runtime.BufferedTokenStream.fetch(BufferedTokenStream.java:133)
>     at
> org.antlr.runtime.BufferedTokenStream.sync(BufferedTokenStream.java:127)
>     at
> org.antlr.runtime.CommonTokenStream.setup(CommonTokenStream.java:132)
>     at org.antlr.runtime.CommonTokenStream.LT(CommonTokenStream.java:91)
>     at
> org.apache.hadoop.hive.ql.parse.HiveParser.statement(HiveParser.java:547)
>     at
> org.apache.hadoop.hive.ql.parse.ParseDriver.parse(ParseDriver.java:438)
>     at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:416)
>     at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:336)
>     at org.apache.hadoop.hive.ql.Driver.run(Driver.java:909)
>     at
> org.apache.hadoop.hive.cli.CliDriver.processLocalCmd(CliDriver.java:258)
>     at org.apache.hadoop.hive.cli.CliDriver.processCmd(CliDriver.java:215)
>     at org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:406)
>     at org.apache.hadoop.hive.cli.CliDriver.run(CliDriver.java:689)
>     at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:557)
>     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>     at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>     at java.lang.reflect.Method.invoke(Method.java:601)
>     at org.apache.hadoop.util.RunJar.main(RunJar.java:156)*
>
> Googled and found several posts with the same issue. Every where it says
> that issue is with version of antlr.jar.
> But I find that antlr.jar is already with correct version inside hive's
> lib directory and I don't think there's any other antlr.jar in my classpath.
>
> 1. What is going wrong?
> 2. Where and what else to be checked?
> 3. How to resolve and start using Hive?
>
> Please guide me.
>
> Regards,
> Sarath.
>
>