Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # dev >> JAXB / Guice errors


Copy link to this message
-
Re: JAXB / Guice errors
Hi Vinod,

I solved my issue. I had a stale version of java pointed to by JAVA_HOME.
$ ./jdk1.6.0_01/bin/java -version
java version "1.6.0_01"
Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
Java HotSpot(TM) Server VM (build 1.6.0_01-b06, mixed mode)

Updating to $ ./jdk1.6.0_30/bin/java -version
java version "1.6.0_30"
Java(TM) SE Runtime Environment (build 1.6.0_30-b12)
Java HotSpot(TM) Server VM (build 20.5-b03, mixed mode)

fixed the problem

Thanks
Ravi
On Tue, Dec 20, 2011 at 12:13 PM, Vinod Kumar Vavilapalli <
[EMAIL PROTECTED]> wrote:

> Can you please open a ticket? It must be related to MAPREDUCE-2863 . Thomas
> can help with this.
>
> Thanks,
> +Vinod
>
>
> On Tue, Dec 20, 2011 at 10:09 AM, Ravi Prakash <[EMAIL PROTECTED]>
> wrote:
>
> > Hi,
> >
> > Is anyone seeing these errors when they try to access the RM Web UI?
> >
> > HTTP ERROR 500
> >
> > Problem accessing /. Reason:
> >
> >    Guice provision errors:
> >
> > 1) Error injecting constructor, java.lang.LinkageError: JAXB 2.1 API is
> > being loaded from the bootstrap classloader, but this RI (from
> >
> >
> jar:file:<somePath>/hadoop-0.23.1-SNAPSHOT/share/hadoop/common/lib/jaxb-impl-2.2.3-1.jar!/com/sun/xml/bind/v2/model/impl/ModelBuilder.class)
> > needs 2.2 API. Use the endorsed directory mechanism to place jaxb-api.jar
> > in the bootstrap classloader. (See
> > http://java.sun.com/j2se/1.6.0/docs/guide/standards/)
> >  at
> >
> >
> org.apache.hadoop.yarn.server.resourcemanager.webapp.JAXBContextResolver.<init>(JAXBContextResolver.java:60)
> >  at
> >
> >
> org.apache.hadoop.yarn.server.resourcemanager.webapp.RMWebApp.setup(RMWebApp.java:45)
> >  while locating
> > org.apache.hadoop.yarn.server.resourcemanager.webapp.JAXBContextResolver
> >
> > 1 error
> >
> > Anyone fix it yet?
> >
> > Cheers
> > Ravi.
> >
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB