Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> hsqldb version problem


Copy link to this message
-
RE: hsqldb version problem
Thank you Arvind,

However, you've  only partially answered my questions:

Q. ...which project do they come with and why do I have two?
>From your response below I understand that 1.8.0.10 hsqldb.jar file comes with Sqoop while 2.2.9 is instaled with CD4.

Q. I replaced hsqldb-1.8.0.10.jar file with hsqldb (ver 2.2.9) and...  after I start the metastore daemon fine and  execute "$sqoop job -list", I  started receiving this error.
ERROR hsqldb.HsqldbJobStorage: To use this version of Sqoop, you must downgrade your metadata schema. How do I do it?

Thanks
AK47

From: Arvind Prabhakar [mailto:[EMAIL PROTECTED]]
Sent: Wednesday, November 14, 2012 7:05 PM
To: [EMAIL PROTECTED]
Subject: Re: hsqldb version problem

[Moving thread to [EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]> as it seems to be CDH related + bcc:user@hadoop.a.o]

Hi,

The underlying issue is that Sqoop depends upon HSQLDB 1.x whereas the default jar bundled with CDH 4 is HSQLDB 2.x. Since this is bundled with Hadoop for example purposes only, you should be able to carefully remove it from the classpath and replace it with the previous version in order to get past this problem.

Regards,
Arvind Prabhakar

On Thu, Nov 8, 2012 at 1:21 PM, Kartashov, Andy <[EMAIL PROTECTED]<mailto:[EMAIL PROTECTED]>> wrote:
Guys,

Please help me out here. Have issue with the versions. Have both hsqldb.jar in 2.2.9 and 1.8.0.10  By the way, which project do they come with and why do I have two? I want to know in case I need to reinstall/upgrade...

The problem is, my Sqoop jobs were initially complaining whenever I tried to run them, looking for 2.2.9 version of hsqldb.jar. Well I resolved that issue by moving the hsqldb-1.8.0.10.jar away and bringing in 2.2.9 one.  All worked fine until I started playing with sqoop metastore. I could start the metastore daemon fine but when I would execute "$sqoop job -list", I  started receiving this error.

ERROR hsqldb.HsqldbJobStorage: To use this version of Sqoop, you must downgrade your metadata schema.
ERROR tool.JobTool: I/O error performing job operation: java.io.IOException: Invalid metadata version.
        at org.apache.sqoop.metastore.hsqldb.HsqldbJobStorage.init(HsqldbJobStorage.java:202)

I realise that  it is to do with me moving the 1.8.0 jar away. But, when I bring it back,  $sqoop import....  jobs don't execute and start complaining again.

p.s. I just installed and are playing with Oozie. I see that it is also using 1.8.0 version of hsqldb.jar file.

So, how to do? How can I start using 1.8.0 jar without issues or else?

My set-up:
Hadoop 2.0.0-cdh4.1.1
Sqoop 1.4.1-cdh4.0.1
Oozie client build version: 3.2.0-cdh4.1.2
Mapreduce-0.20

Rgds,
AK47
NOTICE: This e-mail message and any attachments are confidential, subject to copyright and may be privileged. Any unauthorized use, copying or disclosure is prohibited. If you are not the intended recipient, please delete and contact the sender immediately. Please consider the environment before printing this e-mail. AVIS : le présent courriel et toute pièce jointe qui l'accompagne sont confidentiels, protégés par le droit d'auteur et peuvent être couverts par le secret professionnel. Toute utilisation, copie ou divulgation non autorisée est interdite. Si vous n'êtes pas le destinataire prévu de ce courriel, supprimez-le et contactez immédiatement l'expéditeur. Veuillez penser à l'environnement avant d'imprimer le présent courriel

NOTICE: This e-mail message and any attachments are confidential, subject to copyright and may be privileged. Any unauthorized use, copying or disclosure is prohibited. If you are not the intended recipient, please delete and contact the sender immediately. Please consider the environment before printing this e-mail. AVIS : le présent courriel et toute pièce jointe qui l'accompagne sont confidentiels, protégés par le droit d'auteur et peuvent être couverts par le secret professionnel. Toute utilisation, copie ou divulgation non autorisée est interdite. Si vous n'êtes pas le destinataire prévu de ce courriel, supprimez-le et contactez immédiatement l'expéditeur. Veuillez penser à l'environnement avant d'imprimer le présent courriel
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB