Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo, mail # user - slave tserver not responding


Copy link to this message
-
Re: slave tserver not responding
Christopher 2013-12-31, 23:05
What version?
Also, check the contents of the *.err and *.out logs.
--
Christopher L Tubbs II
http://gravatar.com/ctubbsii
On Tue, Dec 31, 2013 at 6:02 PM, Arshak Navruzyan <[EMAIL PROTECTED]> wrote:

> I configured a new instance with a master and a slave tserver.  When I do
> start-all on the master, the slave doesn't come up.  I am wondering if it's
> because I left the instance secret as the default. (I get an exception when
> I try to change that).
>
> This is what I see in the master's monitor regarding the slave
>
> Non-Functioning Tablet Servers
> The following tablet servers reported a status other than Online
>
>  10.240.203.36:9997 UNRESPONSIVE
> In the master log I see the following
>
> 2013-12-31 22:56:13,665 [master.Master] ERROR: unable to get tablet server
> status 10.240.203.36:9997[1434a79d34404a2]
> org.apache.thrift.transport.TTransportException:
> java.net.NoRouteToHostException: No route to host
> 2013-12-31 22:56:13,712 [master.Master] ERROR: unable to get tablet server
> status 10.240.203.36:9997[1434a79d34404a2]
> org.apache.thrift.transport.TTransportException:
> java.net.NoRouteToHostException: No route to host
> 2013-12-31 22:56:13,802 [balancer.TableLoadBalancer] INFO : Loaded class
> org.apache.accumulo.server.master.balancer.DefaultLoadBalancer for table !0
> 2013-12-31 22:56:13,803 [master.Master] INFO : Assigning 1 tablets
> 2013-12-31 22:56:13,812 [master.Master] ERROR: Error processing table
> state for store Root Tablet
> org.apache.thrift.transport.TTransportException:
> java.net.NoRouteToHostException: No route to host
>         at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.createNewTransport(ThriftTransportPool.java:475)
>         at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.getTransport(ThriftTransportPool.java:464)
>         at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.getTransport(ThriftTransportPool.java:441)
>         at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.getTransportWithDefaultTimeout(ThriftTransportPool.java:366)
>
>
>
> In the slave's tserver.log all I see is
>
> 2013-12-31 22:56:34,731 [tabletserver.TabletServer] FATAL: Lost tablet
> server lock (reason = LOCK_DELETED), exiting.
>
>
>