Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Hive, mail # dev - Problem running hive from eclipse


+
amareshwari sriramdasu 2013-02-21, 13:01
+
Amir Sanjar 2013-02-21, 13:47
Copy link to this message
-
Re: Problem running hive from eclipse
Brock Noland 2013-02-21, 13:44
Hi,

I don't know if this will help but I do a clean package separately and before running eclipse-files. This has always worked, but with a few quirks.

--
Brock Noland
Sent with Sparrow (http://www.sparrowmailapp.com/?sig)
On Thursday, February 21, 2013 at 7:01 AM, amareshwari sriramdasu wrote:

> Hi,
>
> I'm trying to launch junit test from eclipse, it fails with
> ClassNotFoundException.
>
> I did 'ant clean package eclipse-files' and imported the project into
> eclipse, as specified in
> https://cwiki.apache.org/Hive/gettingstarted-eclipsesetup.html.
>
> When I run HIveCLI or TestCliDriver it says
>
> Errors exist in required projects: hive
> Proceed with launch?
>
> When I proceed, it fails with
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/hadoop/hive/cli/CliDriver
>
> Caused by: java.lang.ClassNotFoundException:
> org.apache.hadoop.hive.cli.CliDriver
>
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>
> at java.security.AccessController.doPrivileged(Native Method)
>
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>
> Any help to come out this problem is much appreciated.
>
> Environment :
> OS : Mac OSX Lion 10.7.3
> Java : 1.6.0.jdk
>
> Thanks
> Amareshwari
>
>