Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - regions unlinked from table


Copy link to this message
-
Re: regions unlinked from table
Bryan Beaudreault 2012-07-02, 23:44
I'm on cdh3u2 to be precise.  I don't have the fixMeta option, or any other
special fix options aside from the basic -fix.

I'll take a look at what 0.90.6 version does when it fixes meta.  Maybe I
can just follow what it does there.

Thanks again!

On Mon, Jul 2, 2012 at 7:36 PM, Suraj Varma <[EMAIL PROTECTED]> wrote:

> Are you using apache hbase 0.90.4 ... or the one from CDH3?
> Check what other hbck options you have (do you have -fixMeta?) on the
> version you are on.
>
> What the uber-hbck (part of hbase-0.90.6 and later releases) does is
> "automate" this meta table surgery to fix the issue.
>
> I will let folks who have tried other repair options respond to you.
> --S
>
> On Mon, Jul 2, 2012 at 4:24 PM, Bryan Beaudreault
> <[EMAIL PROTECTED]> wrote:
> > Thanks for the response.
> >
> > hbck consistently shows 7 inconsistencies.  I tried -fix (a few times)
> and
> > it didn't seem to fix it.  I tried -details and it does seem to print out
> > more, but nothing super usable from what I can tell.
> >
> > On Mon, Jul 2, 2012 at 6:32 PM, Suraj Varma <[EMAIL PROTECTED]> wrote:
> >
> >> Try doing an hbase hbck to see if it reports inconsistency. And do an
> >> hbase hbck -fix to see if it fixes it for you. See
> >> http://hbase.apache.org/book.html#hbck.in.depth
> >>
> >> Note that since 0.90.4 is old, some of the documented options won't be
> >> available ... but hbase hbck -fix will be available.
> >> --S
> >>
> >> On Mon, Jul 2, 2012 at 7:34 AM, Bryan Beaudreault
> >> <[EMAIL PROTECTED]> wrote:
> >> > Hey all,
> >> >
> >> > I'm running hbase 0.90.4, and somehow the regions for one of my tables
> >> have
> >> > become unlinked from the table itself.  The Master UI shows no regions
> >> for
> >> > the table, and attempting to call Table.getRegionsInfo() returns
> nothing.
> >> >  However, I can see the regions in hdfs in their proper location and
> >> doing
> >> > a scan of the table via the hbase shell does return results.  I also
> get
> >> > results if I do a Get for a specific rowkey.
> >> >
> >> > How can I get these regions back associated with the table, and any
> idea
> >> > why this may have happened?  I tried grepping the hmaster logs but
> didn't
> >> > see anything relevant.
> >> >
> >> > Thanks!
> >> >
> >> > Bryan
> >>
>