Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Connection error while usinh HBase client API for pseudodistrbuted mode


Copy link to this message
-
Re: Connection error while usinh HBase client API for pseudodistrbuted mode
Change the value of fs.default.name to "hdfs://localhost:8020" and
restart everything again..It should be a combination of host:port.

Regards,
    Mohammad Tariq
On Tue, Jul 3, 2012 at 8:12 PM, AnandaVelMurugan Chandra Mohan
<[EMAIL PROTECTED]> wrote:
> For starting Hbase master manually
>
> I did "cd" to <HBASE_HOME>\bin
> Then did ./hbase master start
>
> Contents of my hbase-site.xml
>
> <configuration>
>     <property>
>       <name>hbase.rootdir</name>
>       <value>hdfs://localhost:8020/user/eucalyptus/hbase</value>
>       <description>The directory shared by RegionServers.
>       </description>
>     </property>
>     <property>
>            <name>hbase.zookeeper.quorum</name>
>            <value>localhost</value>
>        </property>
>       <property>
>            <name>dfs.replication</name>
>            <value>1</value>
>       </property>
>       <property>
>            <name>hbase.zookeeper.property.clientPort</name>
>            <value>2181</value>
>       </property>
>       <property>
>            <name>hbase.zookeeper.property.dataDir</name>
>            <value>/home/eucalyptus/hbase/zookeeper</value>
>        </property>
> </configuration>
>
>
> core-site.xml
>
> <configuration>
> <property>
>     <name>fs.default.name</name>
>     <value>hdfs://localhost/</value>
>
>   </property>
> </configuration>
>
> I could do HDFS operations like get, put in Hadoop. I could also create and
> list tables in Hbase shell.
>
>
> On Tue, Jul 3, 2012 at 7:58 PM, Mohammad Tariq <[EMAIL PROTECTED]> wrote:
>
>> What do you mean by "I tried starting Hbase master manually and I got
>> this error."??..By manually do you mean through the shell??How were
>> you trying to do it earlier??And if possible could you please post the
>> modified core-site.xml and hbase-site.xml files.
>>
>> Regards,
>>     Mohammad Tariq
>>
>>
>> On Tue, Jul 3, 2012 at 7:41 PM, AnandaVelMurugan Chandra Mohan
>> <[EMAIL PROTECTED]> wrote:
>> > Thanks for the link.
>> >
>> > I followed the link and fixed my hdfs url too.
>> >
>> > But when I start hbase, hbase master and zookeeper processes are not
>> > starting
>> >
>> > I tried starting Hbase master manually and I got this error.
>> >
>> > ERROR master.HMasterCommandLine: Failed to start master
>> > java.io.IOException: CRC check failed
>> >
>> > Do you have any idea?
>> > On Tue, Jul 3, 2012 at 6:41 PM, Mohammad Tariq <[EMAIL PROTECTED]>
>> wrote:
>> >
>> >> Not a prob..I was expecting this after looking at the config
>> >> file..First of all your "hbase.rootdir" property must contain the
>> >> "complete" value of the "fs.default.name" property in your hadoop's
>> >> "core-site.xml" file.(This includes "port no" also)..After that just
>> >> add the following properties in your hbase-site.xml file and let me
>> >> know if it is works for you.
>> >>
>> >> <property>
>> >>         <name>hbase.cluster.distributed</name>
>> >>         <value>true</value>
>> >> </property>
>> >>
>> >> <property>
>> >>   <name>hbase.zookeeper.quorum</name>
>> >>   <value>localhost</value>
>> >> </property>
>> >> <property>
>> >>     <name>dfs.replication</name>
>> >>     <value>1</value>
>> >> </property>
>> >> <property>
>> >>       <name>hbase.zookeeper.property.clientPort</name>
>> >>       <value>2181</value>
>> >>       <description>Property from ZooKeeper's config zoo.cfg.
>> >>       The port at which the clients will connect.
>> >>       </description>
>> >>     </property>
>> >>  <property>
>> >>
>> >> For detailed help you can visit this link -
>> >>
>> http://cloudfront.blogspot.in/2012/06/how-to-configure-habse-in-pseudo.html
>> >> ,
>> >> if you want.
>> >>
>> >> Regards,
>> >>     Mohammad Tariq
>> >>
>> >>
>> >> On Tue, Jul 3, 2012 at 6:31 PM, AnandaVelMurugan Chandra Mohan
>> >> <[EMAIL PROTECTED]> wrote:
>> >> > Sorry. I tried list and it returned 0 as no table exists. Then I
>> posted
>> >> > this question.
>> >> >
>> >> > Now when I try create table now, shell is hanging and I get following