Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop >> mail # user >> Fwd: CDH4: sqoop issue in using --direct with Netezza driver


Copy link to this message
-
Fwd: CDH4: sqoop issue in using --direct with Netezza driver
---------- Forwarded message ----------
From: sanjeev sagar <[EMAIL PROTECTED]>
Date: Wed, Dec 19, 2012 at 5:15 PM
Subject: CDH4: sqoop issue in using --direct with Netezza driver
To: [EMAIL PROTECTED]
Cc: sanjeev sagar <[EMAIL PROTECTED]>
Hello, I'm running into a issue while using the Sqoop with Netezza driver
in using the option "--direct". Following are the details

version: Sqoop 1.4.1-cdh4.1.2

Hadoop: Hadoop 2.0.0-cdh4.1.2

command: sqoop --options-file /etc/sqoop/conf/sqoop_nz_remote_import.cnf

--direct --table SILO --num-mappers 1 --escaped-by '\\'

--fields-terminated-by ',' --verbose -- --nz-logdir /tmp/

Error:

12/12/19 15:42:51 ERROR tool.ImportTool: Encountered IOException running
import job: java.io.IOException: Unable to validate object type for given
table. Please ensure that the given user name and table name is in the the
correct case. If you are not sure, please use upper case to specify both
these values.

         at

com.cloudera.sqoop.netezza.DirectNetezzaManager.validateTargetObjectType(DirectNetezzaManager.java:131)

         at

com.cloudera.sqoop.netezza.DirectNetezzaManager.importTable(DirectNetezzaManager.java:196)

         at

org.apache.sqoop.tool.ImportTool.importTable(ImportTool.java:403)

         at org.apache.sqoop.tool.ImportTool.run(ImportTool.java:476)

         at org.apache.sqoop.Sqoop.run(Sqoop.java:145)

         at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)

         at org.apache.sqoop.Sqoop.runSqoop(Sqoop.java:181)

         at org.apache.sqoop.Sqoop.runTool(Sqoop.java:220)

         at org.apache.sqoop.Sqoop.runTool(Sqoop.java:229)

         at org.apache.sqoop.Sqoop.main(Sqoop.java:238)

         at com.cloudera.sqoop.Sqoop.main(Sqoop.java:57)

I've checked the options many times and tried using
db_name/table_name/user_name in all caps but still failing.

In user guide it does mention about this error but no solution as such.

Just say that use username and table_name in same case or use them in caps,
which i did but no help.

I dont' know how else to troubleshoot this to get more details.

anyone any idea to correct this? If I dont' use direct and num-mappers then
it goes fine but very slow. Direct will help in moving faster.

Appreciate any assistance on the issue.

Thanks,

--
Sanjeev Sagar

*"**Separate yourself from everything that separates you from others
!" - Nirankari
Baba Hardev Singh ji *

**

--
Sanjeev Sagar

*"**Separate yourself from everything that separates you from others
!" - Nirankari
Baba Hardev Singh ji *

**