Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> ANN: The 1st hbase 0.94.5 release candidate is available for download


+
lars hofhansl 2013-02-02, 17:29
+
Jean-Marc Spaggiari 2013-02-04, 18:35
+
lars hofhansl 2013-02-05, 04:20
+
Jean-Marc Spaggiari 2013-02-05, 12:14
+
Jean-Daniel Cryans 2013-02-05, 18:26
+
Jean-Marc Spaggiari 2013-02-05, 18:39
+
Ted Yu 2013-02-05, 19:03
+
Jean-Marc Spaggiari 2013-02-05, 19:16
+
Ted Yu 2013-02-05, 19:28
+
Jean-Marc Spaggiari 2013-02-05, 19:40
+
Ted Yu 2013-02-05, 19:47
+
Enis Söztutar 2013-02-05, 19:56
+
lars hofhansl 2013-02-05, 21:26
+
Ted Yu 2013-02-05, 21:19
+
lars hofhansl 2013-02-05, 21:31
+
Ted Yu 2013-02-05, 21:36
+
lars hofhansl 2013-02-05, 21:40
Copy link to this message
-
Re: ANN: The 1st hbase 0.94.5 release candidate is available for download
I think HBASE-7772 should sink the current RC.  It looks like HBASE-7626
broke token authentication in some cases with secure HBase.
On Tue, Feb 5, 2013 at 1:40 PM, lars hofhansl <[EMAIL PROTECTED]> wrote:

> I do not think we can mandate a newer version of ZK in a minor release. At
> least we avoided that in the past.
> HBase "ships" with ZK 3.4.5, but that really just means the client. It
> still has to work with older ZK servers.
>
> -- Lars
>
>
>
> ________________________________
>  From: Ted Yu <[EMAIL PROTECTED]>
> To: [EMAIL PROTECTED]; lars hofhansl <[EMAIL PROTECTED]>
> Sent: Tuesday, February 5, 2013 1:36 PM
> Subject: Re: ANN: The 1st hbase 0.94.5 release candidate is available for
> download
>
> I think it would be prudent to sink RC0.
>
> The fix for HBASE-7771 is shaping up. As long as user deploys 0.94.5 (RC1)
> with zookeeper client of 3.4.4 or newer, there should be no problem.
>
> Cheers
>
> On Tue, Feb 5, 2013 at 1:31 PM, lars hofhansl <[EMAIL PROTECTED]> wrote:
>
> > You'd recommend sinking this RC for this rather than having this next
> > months in 0.94.6?
> >
> > I'm fine either way. With many, smaller, and backward compatible releases
> > it should be less important to fix a particular problem in a specific
> > release.
> >
> > Looks like this problem was introduced with 0.94.4, and it that case it
> > might be prudent to get this in.
> >
> > So... Wanna sink this RC?
> >
> >
> > -- Lars
> >
> >
> >
> > ________________________________
> >  From: Ted Yu <[EMAIL PROTECTED]>
> > To: [EMAIL PROTECTED]
> > Sent: Tuesday, February 5, 2013 1:19 PM
> > Subject: Re: ANN: The 1st hbase 0.94.5 release candidate is available for
> > download
> >
> > Francis reminded me that ZOOKEEPER-1437 is a client side fix.
> >
> > So our situation is simplified: 0.94.5 ships with zookeeper 3.4.5
> > client. HBASE-7771 should be included.
> >
> > Cheers
> >
> > On Tue, Feb 5, 2013 at 11:47 AM, Ted Yu <[EMAIL PROTECTED]> wrote:
> >
> > > Auto-detection may be difficult.
> > > 0.94.5 uses the following config param for usage of multi() feature in
> > > zookeeper 3.4 :
> > >
> > >   <property>
> > >     <name>hbase.zookeeper.useMulti</name>
> > >     <value>false</value>
> > >
> > > Since the issue HBASE-7771 tries to solve affects zookeeper 3.4.4 and
> > > later version(s), the above config param would not suffice (for current
> > > discussion).
> > >
> > > Cheers
> > >
> > > On Tue, Feb 5, 2013 at 11:40 AM, Jean-Marc Spaggiari <
> > > [EMAIL PROTECTED]> wrote:
> > >
> > >> Yes, I can easily upgrade to 3.4.5, but I think some might not want to
> > >> if zookeeper is used by some other applications.
> > >>
> > >> So I agree that we should consider something to detect ZK version and
> > >> decide, based on that, ifthe workaround should be used. And if this
> > >> can be done automatically instead of setting up something in the conf
> > >> files, it's even better...
> > >>
> > >> 2013/2/5, Ted Yu <[EMAIL PROTECTED]>:
> > >> > This is tricky.
> > >> > Is it possible to upgrade standalone zookeeper to 3.4.5 when you
> > >> upgrade to
> > >> > HBase 0.94.5 ?
> > >> >
> > >> > Anyway, looks like we need some config parameter that tells us the
> > >> version
> > >> > of standalone zookeeper :-) so that we can decide whether the
> > workaround
> > >> > should be used.
> > >> >
> > >> > On Tue, Feb 5, 2013 at 11:16 AM, Jean-Marc Spaggiari <
> > >> > [EMAIL PROTECTED]> wrote:
> > >> >
> > >> >> Hi Ted,
> > >> >>
> > >> >> Does it mean that 0.94.5 will not work anymore for those running
> > >> >> zookeeper separatly with a version < 3.4.5?
> > >> >>
> > >> >> I'm running 3.4.3 in my cluster...
> > >> >>
> > >> >> JM
> > >> >>
> > >> >> 2013/2/5, Ted Yu <[EMAIL PROTECTED]>:
> > >> >> > Patch is available for:
> > >> >> > HBASE-7771 Secure HBase Client in MR job causes tasks to wait
> > forever
> > >> >> >
> > >> >> > It removes the workaround from HBASE-4791 which went into 0.94.4
> > >> >> >
> > >> >> > Now that zookeeper 3.4.5 is used by 0.94.5, I think HBASE-7771
+
Lars Hofhansl 2013-02-06, 04:21
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB