Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop >> mail # dev >> Discussing solutions to Sqoop1 and Sqoop2 confusion (was: Code name for Sqoop 2)


Copy link to this message
-
Re: Discussing solutions to Sqoop1 and Sqoop2 confusion (was: Code name for Sqoop 2)
Thanks to everyone contributing to the discussion.

I think it makes sense to mark Sqoop2 as Sqoop-1.99.3-prerelease and
make our site a bit clearer about its lack of backward compatibility.

If this doesn't help - we can re-visit the rename idea.

How about taking the following steps:
- Change the blurb on our front page from:
"Latest stable release is 1.4.4 (download, documentation). Latest cut
of Sqoop2 is 1.99.3 (download, documentation)."

to:
"Latest stable release is 1.4.4 (download, documentation). Latest
experimental release is 1.99.3 (download, documentation) - Note that
1.99.3 is not compatible with 1.4.4 and not feature complete."

- Change all references to 1.99.3 to "1.99.3-prerelease"

- Add clarifications in Sqoop2 docs that Sqoop1 parameters and
connectors are not supported.

- I'd like to also change the name of our Sqoop2 shell client to
something less confusing, but can't think of anything good here :)

What do you think?

Gwen
On Fri, Aug 8, 2014 at 4:17 PM, Kathleen Ting <[EMAIL PROTECTED]> wrote:

 
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB