Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo >> mail # user >> 1.5.0-RC1 Test release candidate


+
Christopher 2013-05-04, 16:10
+
Drew Farris 2013-05-07, 13:55
+
Eric Newton 2013-05-07, 14:55
+
Eric Newton 2013-05-07, 17:07
+
Eric Newton 2013-05-08, 15:54
+
Christopher 2013-05-08, 20:41
+
Christopher 2013-05-07, 17:34
Copy link to this message
-
Re: 1.5.0-RC1 Test release candidate
On Tue, May 7, 2013 at 1:34 PM, Christopher <[EMAIL PROTECTED]> wrote:

> I opened https://issues.apache.org/jira/browse/ACCUMULO-1384 to deal
> with the bin/config.sh bug. I still think the best option is to drop
> version numbers from the filenames to simplify things a bit, but would
> feel more comfortable doing that if more people were on board with
> that.
>

I am not opposed to the concept.  Are you thinking of doing this for 1.5?
 For 1.5 it seems like just changing the version in config.sh would be less
likely to introduce into bugs the various scripts.   But I guess this
change can not be automated w/ maven which has its own set of issues.
 Since I am uncertain, I'll just go with whatever you think is best.
>
> Yes, the binary (dist) tarball is under the assemble module, because
> of the way maven builds them. It's not the best solution, but it's
> where Maven automatically puts them when it stages build artifacts,
> and is unavoidable unless we do additional steps to rename the file
> after staging (which we can still do, if necessary). It has been
> suggested (Eric) that the "assemble" module could simply be called
> "apache-accumulo" (distinct from our parent POM called "accumulo"), so
> that the binary tarball would be named properly. I'm somewhat on board
> with that idea for future versions, but not 100% certain it's the best
> solution for the naming convention confusion.
>

AFAIK, we do no thave to name the dir that comes from the tar ball
apache-accumulo.  Seems like we should not worry about this for 1.5.

>
> The naming convention for the source tarball is going to be different,
> simply because it is now following the Apache parent POM's naming
> convention for source-release assemblies.
>
> --
> Christopher L Tubbs II
> http://gravatar.com/ctubbsii
>
>
> On Tue, May 7, 2013 at 1:07 PM, Eric Newton <[EMAIL PROTECTED]> wrote:
> > I'm looking at the assembly bin tar ball:
> >
> >
> https://repository.apache.org/content/repositories/orgapacheaccumulo-177/org/apache/accumulo/accumulo-assemble/1.5.0/accumulo-assemble-1.5.0-bin.tar.gz
> >
> > I checked the signature, MD5.
> > I ran into the config.sh bug, but worked around it by setting
> > ACCUMULO_VERSION in conf/accumulo-env.sh
> > I've kicked off continuous ingest on a 10 node test cluster, performance
> is
> > good with the default 3G config: about a billion k-v/hour with agitation.
> >
> > The naming convention for the tar file is different.
> > The unpacked directory name is different.
> >
> > I can live with these changes, but I wanted to point it out.
> >
> > Thank you, Christopher, for taking over the build process and getting it
> > more inline with maven conventions.
> >
> > -Eric
> >
> >
> >
> > On Tue, May 7, 2013 at 10:55 AM, Eric Newton <[EMAIL PROTECTED]>
> wrote:
> >>
> >> They are under the assemble project:
> >>
> >>
> >>
> https://repository.apache.org/content/repositories/orgapacheaccumulo-177/org/apache/accumulo/accumulo-assemble/1.5.0/
> >>
> >> -Eric
> >>
> >>
> >> On Tue, May 7, 2013 at 9:55 AM, Drew Farris <[EMAIL PROTECTED]> wrote:
> >>>
> >>> Chris,
> >>>
> >>> Should the binary tarball release be present in there somewhere?
> >>>
> >>> I only see the source tarballs in
> >>>
> https://repository.apache.org/content/repositories/orgapacheaccumulo-177/org/apache/accumulo/accumulo/1.5.0/
> >>>
> >>> Drew
> >>>
> >>>
> >>> On Sat, May 4, 2013 at 12:10 PM, Christopher <[EMAIL PROTECTED]>
> wrote:
> >>>>
> >>>> I've put together a release candidate (RC1) for 1.5.0.
> >>>>
> >>>> Please review it and provide feedback. Thanks!
> >>>>
> >>>>
> >>>>
> https://repository.apache.org/content/repositories/orgapacheaccumulo-177/
> >>>>
> >>>> --
> >>>> Christopher L Tubbs II
> >>>> http://gravatar.com/ctubbsii
> >>>>
> >>>>
> >>>>
> >>>> ---------- Forwarded message ----------
> >>>> From: Nexus Repository Manager <[EMAIL PROTECTED]>
> >>>> Date: Sat, May 4, 2013 at 12:01 PM
> >>>> Subject: Nexus: Staging Completed.
> >>>> To: Christopher Tubbs <[EMAIL PROTECTED]>
+
Christopher 2013-05-07, 21:10
+
Christopher 2013-05-07, 17:35
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB