Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Important "Undefined Error"


Copy link to this message
-
RE: Important "Undefined Error"


Hi Shashwat,
I will try it but can u send me your core-site.xml and mapred-site.xml, hdfs-site.xml as well.
Have u added any lines to zoo.cfg ???
> From: [EMAIL PROTECTED]
> To: [EMAIL PROTECTED]
> Subject: RE: Important "Undefined Error"
> Date: Sat, 12 May 2012 23:31:49 +0530
>
> The problem is your hbase is not able to connect to Hadoop, can you put your
> hbase-site.xml content >> here.. have you specified localhost somewhere, if
> so remove localhost from everywhere and put your hdfsl namenode address
> suppose your namenode is running on master:9000 then put your hbase file
> system setting as master:9000/hbase here I am sending you the configuration
> which I am using in hbase and is working
>
>
> My hbase-site.xml content is
>
> <?xml version="1.0"?>
> <?xml-stylesheet type="text/xsl" href="configuration.xsl"?>
> <!--
> /**
>  * Copyright 2010 The Apache Software Foundation
>  *
>  * Licensed to the Apache Software Foundation (ASF) under one
>  * or more contributor license agreements.  See the NOTICE file
>  * distributed with this work for additional information
>  * regarding copyright ownership.  The ASF licenses this file
>  * to you under the Apache License, Version 2.0 (the
>  * "License"); you may not use this file except in compliance
>  * with the License.  You may obtain a copy of the License at
>  *
>  *     http://www.apache.org/licenses/LICENSE-2.0
>  *
>  * Unless required by applicable law or agreed to in writing, software
>  * distributed under the License is distributed on an "AS IS" BASIS,
>  * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
>  * See the License for the specific language governing permissions and
>  * limitations under the License.
>  */
> -->
> <configuration>
> <property>
> <name>hbase.rootdir</name>
> <value>hdfs://master:9000/hbase</value>
> </property>
> <property>
> <name>hbase.master</name>
> <value>master:60000</value>
> <description>The host and port that the HBase master runs at.</description>
> </property>
> <property>
> <name>hbase.regionserver.port</name>
> <value>60020</value>
> <description>The host and port that the HBase master runs at.</description>
> </property>
> <!--<property>
> <name>hbase.master.port</name>
> <value>60000</value>
> <description>The host and port that the HBase master runs at.</description>
> </property>-->
> <property>
> <name>hbase.cluster.distributed</name>
> <value>true</value>
> </property>
> <property>
> <name>hbase.tmp.dir</name>
> <value>/home/shashwat/Hadoop/hbase-0.90.4/temp</value>
> </property>
> <property>
> <name>hbase.zookeeper.quorum</name>
> <value>master</value>
> </property>
> <property>
> <name>dfs.replication</name>
> <value>1</value>
> </property>
> <property>
> <name>hbase.zookeeper.property.clientPort</name>
> <value>2181</value>
> <description>Property from ZooKeeper's config zoo.cfg.
> The port at which the clients will connect.
> </description>
> </property>
> <property>
> <name>hbase.zookeeper.property.dataDir</name>
> <value>/home/shashwat/zookeeper</value>
> <description>Property from ZooKeeper's config zoo.cfg.
> The directory where the snapshot is stored.
> </description>
> </property>
>
> </configuration>
>
>
>
>
> Check this out, and also stop hbase, If its not stopping kill all the
> processes, and after putting your  hdfs-site.xml, mapred-site.xml and
> core-site.sml to hbase conf directory try to restart, and also delete the
> folders created by hbase ,,, like temp directory or other then try to start.
>
> Regards
> ∞
> Shashwat Shriparv
>
>
> -----Original Message-----
> From: Dalia Sobhy [mailto:[EMAIL PROTECTED]]
> Sent: 12 May 2012 22:48
> To: [EMAIL PROTECTED]
> Subject: RE: Important "Undefined Error"
>
>
> Hi Shashwat,
> I want to tell you about my configurations:
> I am using 4 nodesOne "Master": Namenode, SecondaryNamenode, Job Tracker,
> Zookeeper, HMasterThree "Slaves": datanodes, tasktrackers, regionservers In
> both master and slaves, all the hadoop daemons are working well, but as for