Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # user >> Accumulo 1.4, No Monitor Statistics for "Accumulo Master"


Copy link to this message
-
Re: Accumulo 1.4, No Monitor Statistics for "Accumulo Master"
Charles,

Thanks for taking the time to inform everyone of the problem and how you
fixed it.

On 5/13/13 10:44 AM, Ott, Charles H. wrote:
>
> I was able to debug this one on my own.  Looking through the monitor's
> debug logs I saw that the user running the monitor service did not
> have READ & EXECUTE permissions on the HDFS path:
>
> /tmp/hadoop-mapred/mapred/system. I perform "hadoop fs -chmod --R 755
> /tmp/hadoop-mapred/mapred/system" and restarted the monitor service.  
> The statistics are now showing up in the Accumulo master table in the
> monitor.
>
> *From:*[EMAIL PROTECTED]
> [mailto:[EMAIL PROTECTED]]
> *On Behalf Of *Ott, Charles H.
> *Sent:* Monday, May 13, 2013 10:28 AM
> *To:* [EMAIL PROTECTED]
> *Subject:* Accumulo 1.4, No Monitor Statistics for "Accumulo Master"
>
> Hi, I am trying to figure out why the monitor is not displaying the
> "Accumulo Master" statistics. Everything else seems to be running just
> fine.  I am not seeing any errors in the Accumulo log files either.  
> Here is what I mean:
>
> http://accumulo.apache.org/images/overview2.png -- This screenshot
> displays the monitor.  In the Top left-most table the Accumulo Master
> information is displayed.  This is not showing up on my instance.  The
> Table appears with the Accumulo Master hyperlink in the header, but
> nothing else. The hyperlink in the header works and when I click it,
> and the Master status is displayed in a new page with the following
> statistics:
>
> #Online Tablet Servers: 1
>
> #Total Tablet Servers: 1
>
> Loggers: 1
>
> Last GC: (5 minutes ago, from current serve datetime stamp)
>
> #Tablets: 4
>
> #Unassigned Tablets: 0
>
> Entries: 35
>
> Ingest: 0
>
> Query: 0
>
> Hold Time: --
>
> OS Load: 0.01
>
> I am able to use the Accumulo shell to login, create a table and add
> entries.
>
> I am running Accumulo 1.4.3 on CentOS 6.3.   The version of Hadoop I
> am running is, Hadoop 0.20.2-cdh3u4.  Zookeeper 3.3.5+19.1
>
> The VM has 4 GB of RAM and is currently at 1018/3829 MB. (2.8GB free)
>
> I have verified that the following Accumulo processes are running:
>
> tserver, logger, master, gc, and monitor.
>
> Thank you for your time.
>
> **
>
> **
>
> *Charles*
>

NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB