Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo, mail # user - Accumulo and CDH4 -- "no tablet servers"


Copy link to this message
-
Re: Accumulo and CDH4 -- "no tablet servers"
Josh Elser 2013-04-05, 22:50
Elise,

Check the tserver_*.{log,out} files. The exception is in the tracer log
is probably a separate issue but won't keep you from running Accumulo.

A good sanity check is to make sure you don't have stray jars in lib and
that ACCUMULO_HOME is correctly set.

On 04/05/2013 06:46 PM, Newman, Elise wrote:
>
> I am trying to properly configure Accumulo on a cluster running CDH4.
> I can't seem to get any tablet servers up and running.
>
> I've checked out trunk, built it against cdh4, and ran ./accumulo init.
>
> Then I ran the start-all script, which produced the following output:
>
> ./start-all.sh
>
> Starting monitor on localhost
>
> Starting tablet servers ..... done
>
> Starting tablet server on *********
>
> Starting tablet server on *********
>
> 2013-04-05 13:04:05,442 [server.Accumulo] INFO : Attempting to talk to
> zookeeper
>
> 2013-04-05 13:04:05,623 [server.Accumulo] INFO : Zookeeper connected
> and initialized, attemping to talk to HDFS
>
> 2013-04-05 13:04:05,766 [server.Accumulo] INFO : Connected to HDFS
>
> Starting master on ********
>
> Starting garbage collector on localhost
>
> Starting tracer on localhost
>
> When I checked http://localhost:50095/tservers, however, it showed
> that there were no tablet servers online. I looked at
> http://localhost:50095/log, and saw the following message:
>
> WARN: There are no tablet servers: check that zookeeper and accumulo
> are running.
>
> I get the same message when I attempt to start the accumulo shell.
>
> In my tracer_master.debug.log I see the following recurring exception:
>
> 2013-04-05 15:15:59,742 [impl.ServerClient] DEBUG: ClientService
> request failed null, retrying ...
>
> org.apache.thrift.transport.TTransportException: Failed to connect to
> a server
>
> at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.getAnyTransport(ThriftTransportPool.java:437)
>
> at
> org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:152)
>
> at
> org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:128)
>
> at
> org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:123)
>
> at
> org.apache.accumulo.core.client.impl.ServerClient.executeRaw(ServerClient.java:86)
>
> at
> org.apache.accumulo.core.client.impl.ServerClient.execute(ServerClient.java:59)
>
> at
> org.apache.accumulo.server.client.HdfsZooInstance.getAuthenticatorClassName(HdfsZooInstance.java:209)
>
> at
> org.apache.accumulo.server.client.HdfsZooInstance.getAuthenticator(HdfsZooInstance.java:219)
>
> at
> org.apache.accumulo.server.trace.TraceServer.<init>(TraceServer.java:178)
>
> at org.apache.accumulo.server.trace.TraceServer.main(TraceServer.java:256)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> at java.lang.reflect.Method.invoke(Method.java:597)
>
> at org.apache.accumulo.start.Main$1.run(Main.java:101)
>
> at java.lang.Thread.run(Thread.java:662)
>
> Anyone know what could be going on?
>
> Thanks in advance,
>
> Elise
>