Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> avro generated code and m2eclipse


+
Michael Drzal 2012-08-09, 18:24
Copy link to this message
-
Re: avro generated code and m2eclipse
If you run 'mvn generate-sources' it should make the avro sources, which
you can then reference from the eclipse project. The docs overlooks that a
little bit.

I think there is a comment somewhere in the ref guide about 'if anything
fails, just try doing 'mvn clean install' and then try again' :)
-------------------
Jesse Yates
@jesse_yates
jyates.github.com
On Thu, Aug 9, 2012 at 11:24 AM, Michael Drzal <[EMAIL PROTECTED]> wrote:

> The other day, I was setting up an hbase dev environment with eclipse on a
> new machine.  I was following the directions on
> http://hbase.apache.org/book/ides.html#eclipse.  After I got everything
> imported, I noticed that I had a ton of errors in eclipse.  After poking
> around a bit, I found that avro didn't generate any sources.  If I run the
> maven build from the command line, everything works as expected.  I did a
> little bit of digging, and I found
> https://issues.apache.org/jira/browse/AVRO-1068.  I've tried playing
> around
> with it a bit, but I'm not enough of a maven wizard to get m2eclipse to do
> the right thing.  Is this expected?  Does anyone have any suggestions on
> how to fix this?
>
>   Mike
>
+
Michael Drzal 2012-08-09, 20:05
+
Jesse Yates 2012-08-10, 16:13
+
Michael Drzal 2012-08-16, 19:29
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB