Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Flume >> mail # dev >> Maven error


+
Harish Mandala 2012-10-31, 22:11
+
Mike Percy 2012-10-31, 22:19
+
Harish Mandala 2012-10-31, 23:25
+
Mike Percy 2012-10-31, 23:35
+
Harish Mandala 2012-11-01, 02:00
+
Mike Percy 2012-11-01, 02:30
+
Harish Mandala 2012-11-02, 14:23
Copy link to this message
-
Re: Maven error
Great!

On Fri, Nov 2, 2012 at 7:23 AM, Harish Mandala <[EMAIL PROTECTED]>wrote:

> Hi,
>
> Thanks, it does work now. I'm on OpenJDK 7.
>
> Regards,
> Harish
>
> On Wed, Oct 31, 2012 at 10:30 PM, Mike Percy <[EMAIL PROTECTED]> wrote:
>
> > Try mvn clean install -DskipTests
> >
> > What JDK version are you using?
> >
> >
> > On Wed, Oct 31, 2012 at 7:00 PM, Harish Mandala <[EMAIL PROTECTED]
> > >wrote:
> >
> > > I tried checking out a clean copy and mvn package -DskipTests, it gives
> > me
> > > the same error. Could it really be a JDK issue?
> > >
> > > On Wed, Oct 31, 2012 at 7:35 PM, Mike Percy <[EMAIL PROTECTED]> wrote:
> > >
> > > > That should work fine. I'm using JDK6u37 from Oracle on Mac OS 10.7
> and
> > > it
> > > > works for me. I have not tested OpenJDK or Oracle JDK7.
> > > >
> > > > Make sure you are using the Git repository linked from here:
> > > > http://flume.apache.org/source.html - try with branch trunk.
> > > >
> > > > And try running with "mvn clean install -DskipTests" (optionally with
> > the
> > > > rat param you are providing)
> > > >
> > > > Regards,
> > > > Mike
> > > >
> > > > On Wed, Oct 31, 2012 at 4:25 PM, Harish Mandala <
> > [EMAIL PROTECTED]
> > > > >wrote:
> > > >
> > > > > Hello,
> > > > >
> > > > > I'm on 3.0.4. Which one should I be on?
> > > > >
> > > > > Thanks,
> > > > > Harish
> > > > >
> > > > > On Wed, Oct 31, 2012 at 6:19 PM, Mike Percy <[EMAIL PROTECTED]>
> > wrote:
> > > > >
> > > > > > Harish are you running Maven 3.0?
> > > > > >
> > > > > > On Wed, Oct 31, 2012 at 3:11 PM, Harish Mandala <
> > > > [EMAIL PROTECTED]
> > > > > > >wrote:
> > > > > >
> > > > > > > Hello,
> > > > > > >
> > > > > > > I do:
> > > > > > > mvn package -DskipTests -Drat.numUnapprovedLicenses=10 -X
> > > > > > >
> > > > > > >
> > > > > > > Here are the Debug logs. I'm pretty sure it's not a network
> > issue.
> > > > > > >
> > > > > > > [ERROR] Failed to execute goal
> > > > > > >
> org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate-jar
> > > > > > > (javadoc-jar) on project flume-parent: Execution javadoc-jar of
> > > goal
> > > > > > >
> org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate-jar
> > > > > failed:
> > > > > > > Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.8.1 or
> one
> > > of
> > > > > its
> > > > > > > dependencies could not be resolved: Failed to collect
> > dependencies
> > > > for
> > > > > > > org.apache.maven.plugins:maven-javadoc-plugin:jar:2.8.1 ():
> > Failed
> > > to
> > > > > > read
> > > > > > > artifact descriptor for
> > > > > > > org.apache.maven.shared:maven-common-artifact-filters:jar:1.3:
> > > Could
> > > > > not
> > > > > > > transfer artifact
> > > > > > > org.apache.maven.shared:maven-common-artifact-filters:pom:1.3
> > > from/to
> > > > > > > repo1.maven.org (http://repo1.maven.org/maven2): Connection
> > reset
> > > ->
> > > > > > [Help
> > > > > > > 1]
> > > > > > > org.apache.maven.lifecycle.LifecycleExecutionException: Failed
> to
> > > > > execute
> > > > > > > goal
> > > > org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate-jar
> > > > > > > (javadoc-jar) on project flume-parent: Execution javadoc-jar of
> > > goal
> > > > > > >
> org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate-jar
> > > > > failed:
> > > > > > > Plugin org.apache.maven.plugins:maven-javadoc-plugin:2.8.1 or
> one
> > > of
> > > > > its
> > > > > > > dependencies could not be resolved: Failed to collect
> > dependencies
> > > > for
> > > > > > > org.apache.maven.plugins:maven-javadoc-plugin:jar:2.8.1 ()
> > > > > > >     at
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
> > > > > > >     at
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
> > > > > > >     at
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB