Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # dev - Re: [External] Re: Need help getting Accumulo running.


+
John Vines 2012-07-06, 02:46
+
Park, Jee [USA] 2012-07-06, 14:32
+
Adam Fuchs 2012-07-06, 14:40
+
Park, Jee [USA] 2012-07-06, 01:21
+
David Medinets 2012-07-06, 02:40
+
Jim Klucar 2012-07-06, 01:25
+
Park, Jee [USA] 2012-07-06, 01:26
+
Jim Klucar 2012-07-06, 01:30
+
Park, Jee [USA] 2012-07-06, 01:31
+
Jim Klucar 2012-07-06, 01:35
+
Park, Jee [USA] 2012-07-06, 01:39
+
Park, Jee [USA] 2012-07-06, 01:37
+
Jim Klucar 2012-07-06, 01:41
+
Park, Jee [USA] 2012-07-06, 01:44
+
Jim Klucar 2012-07-06, 01:47
+
Park, Jee [USA] 2012-07-02, 17:21
+
Jim Klucar 2012-07-02, 17:24
+
Miguel Pereira 2012-07-02, 17:40
+
Eric Newton 2012-07-02, 17:41
+
Park, Jee [USA] 2012-07-02, 17:42
Copy link to this message
-
Re: [External] Re: Need help getting Accumulo running.
William Slacum 2012-07-02, 17:45
Make sure that /var/zookeeper is writable by the user you're launching
Zookeeper as. Alternatively, you can reconfigure zookeeper's zoo.cfg file
to change the directory to somewhere that is writable.

On Mon, Jul 2, 2012 at 1:42 PM, Park, Jee [USA] <[EMAIL PROTECTED]> wrote:

> Ah, so I realized I wasn’t running hadoop or zookeeper, and so I am running
> hadoop, but cannot get zookeeper to run
> Here is what I did:
>
> $ $ZOOKEEPER_HOME/bin/zkServer.sh start
> JMX enabled by default
> Using config: /usr/lib/zookeeper/bin/../conf/zoo.cfg
> Starting zookeeper ... /usr/lib/zookeeper/bin/zkServer.sh: 110:
> /usr/lib/zookeeper/bin/zkServer.sh: Cannot create
> /var/zookeeper/zookeeper_server.pid: Permission denied
> FAILED TO WRITE PID
>
>
> -----Original Message-----
> From: Jim Klucar [mailto:[EMAIL PROTECTED]]
> Sent: Monday, July 02, 2012 1:25 PM
> To: [EMAIL PROTECTED]
> Subject: Re: [External] Re: Need help getting Accumulo running.
>
> Did you verify that zookeeper is running?
>
> On Mon, Jul 2, 2012 at 1:21 PM, Park, Jee [USA] <[EMAIL PROTECTED]> wrote:
> > Thanks everyone for the responses!
> >
> > So, I got hadoop to run and installed accumulo following Miguel's
> > email, the problem now is that when I do
> >
> > $ bin/accumulo init
> >
> > It tries to connect a few times and then times out. Here is what it
> > prints out.
> > Just to let you know I did not change anything in the
> > accumulo-site.xml file
> >
> > Thanks,
> > Jee
> >
> > hduser@ubuntu:~/accumulo$ bin/accumulo init
> > 02 10:10:07,567 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 0 time(s).
> > 02 10:10:08,573 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 1 time(s).
> > 02 10:10:09,574 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 2 time(s).
> > 02 10:10:10,576 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 3 time(s).
> > 02 10:10:11,578 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 4 time(s).
> > 02 10:10:12,580 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 5 time(s).
> > 02 10:10:13,581 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 6 time(s).
> > 02 10:10:14,583 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 7 time(s).
> > 02 10:10:15,585 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 8 time(s).
> > 02 10:10:16,587 [ipc.Client] INFO : Retrying connect to server:
> > localhost/127.0.0.1:54310. Already tried 9 time(s).
> > 02 10:10:16,592 [util.Initialize] FATAL: java.net.ConnectException:
> > Call to
> > localhost/127.0.0.1:54310 failed on connection exception:
> > java.net.ConnectException: Connection refused
> > java.net.ConnectException: Call to localhost/127.0.0.1:54310 failed on
> > connection exception: java.net.ConnectException: Connection refused at
> > org.apache.hadoop.ipc.Client.wrapException(Client.java:767)
> > at org.apache.hadoop.ipc.Client.call(Client.java:743)
> > at org.apache.hadoop.ipc.RPC$Invoker.invoke(RPC.java:220)
> > at $Proxy0.getProtocolVersion(Unknown Source) at
> > org.apache.hadoop.ipc.RPC.getProxy(RPC.java:359)
> > at
> > org.apache.hadoop.hdfs.DFSClient.createRPCNamenode(DFSClient.java:106)
> > at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:207)
> > at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:170)
> > at
> > org.apache.hadoop.hdfs.DistributedFileSystem.initialize(DistributedFil
> > eSyste
> > m.java:82)
> > at
> > org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:1378)
> > at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:66)
> > at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:1390)
> > at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:196)
+
Park, Jee [USA] 2012-07-02, 19:27
+
Jim Klucar 2012-07-02, 19:55
+
Miguel Pereira 2012-07-02, 17:45
+
Park, Jee [USA] 2012-07-02, 17:46
+
Jim Klucar 2012-07-02, 17:50
+
John Vines 2012-07-06, 14:51