Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> cloudera4.2 source code ant


Copy link to this message
-
Re: cloudera4.2 source code ant
Folks, this is Apache Hadoop mailing list. For vendor distro related questions, please use the appropriate vendor mailing list.

Sent from a mobile device

On May 17, 2013, at 2:06 AM, Kun Ling <[EMAIL PROTECTED]> wrote:

> Hi dylan,
>
>      I have not build CDH source code using ant, However I have met a similar dependencies resolve filed problem.
>
>     Acccording to my experience,   this is much like a package network download issue.
>
>     You may try to remove the .ivy2  and .m2   directories in your home directory, and  run "ant clean; ant" to try again.
>
>
>    Hope it is helpful to you.
>
>
> yours,
> Kun Ling
>
>
> On Fri, May 17, 2013 at 4:42 PM, dylan <[EMAIL PROTECTED]> wrote:
>> hello,
>>
>>      there is a problem i can't resolved, i want to remote connect the hadoop ( cloudera cdh4.2.0 ) via eclipse plugin.There’s have no hadoop-eclipse-pluge.jar ,so i download the  hadoop of cdh4.2.0  tarbal and when i complie, the error is below:
>>
>>  
>>
>> ivy-resolve-common:
>>
>> [ivy:resolve] :: resolving dependencies :: org.apache.hadoop#eclipse-plugin;working@master
>>
>> [ivy:resolve]    confs: [common]
>>
>> [ivy:resolve]    found commons-logging#commons-logging;1.1.1 in maven2
>>
>> [ivy:resolve] :: resolution report :: resolve 5475ms :: artifacts dl 2ms
>>
>>        ---------------------------------------------------------------------
>>
>>        |                  |            modules            ||   artifacts   |
>>
>>        |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
>>
>>        ---------------------------------------------------------------------
>>
>>        |      common      |   2   |   0   |   0   |   0   ||   1   |   0   |
>>
>>        ---------------------------------------------------------------------
>>
>> [ivy:resolve]
>>
>> [ivy:resolve] :: problems summary ::
>>
>> [ivy:resolve] :::: WARNINGS
>>
>> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>>
>> [ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
>>
>> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>>
>> [ivy:resolve]           :: log4j#log4j;1.2.16: several problems occurred while resolving dependency: log4j#log4j;1.2.16 {common=[master]}:
>>
>> [ivy:resolve]    reactor-repo: unable to get resource for log4j#log4j;1.2.16: res=${reactor.repo}/log4j/log4j/1.2.16/log4j-1.2.16.pom: java.net.MalformedURLException: no protocol: ${reactor.repo}/log4j/log4j/1.2.16/log4j-1.2.16.pom
>>
>> [ivy:resolve]    reactor-repo: unable to get resource for log4j#log4j;1.2.16: res=${reactor.repo}/log4j/log4j/1.2.16/log4j-1.2.16.jar: java.net.MalformedURLException: no protocol: ${reactor.repo}/log4j/log4j/1.2.16/log4j-1.2.16.jar
>>
>> [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>>
>> [ivy:resolve]
>>
>> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
>>
>>  
>>
>> BUILD FAILED
>>
>> /home/paramiao/hadoop-2.0.0-mr1-cdh4.2.0/src/contrib/build-contrib.xml:440: impossible to resolve dependencies:
>>
>>        resolve failed - see output for details
>>
>>  
>>
>> so could someone tell me where i am wrong and how could make it success?
>>
>>  
>>
>> best regards!
>>
>
>
>
> --
> http://www.lingcc.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB