Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Flume >> mail # dev >> Moving Apache Flume to Java 7


+
Israel Ekpo 2013-04-15, 03:08
+
Mike Percy 2013-04-15, 03:51
Copy link to this message
-
Re: Moving Apache Flume to Java 7
Thanks.

On 14 April 2013 23:51, Mike Percy <[EMAIL PROTECTED]> wrote:

> Hi Israel,
> Many users continue to deploy Flume on Java 6. If people want to run Flume
> against Java 7, it will work, but we cannot drop support for
> compiling/running with Java 6.
>
> Regards,
> Mike
>
> On Apr 14, 2013, at 8:08 PM, Israel Ekpo <[EMAIL PROTECTED]> wrote:
>
> > Developers,
> >
> > I was reading the following excerpt from the Oracle website a couple of
> > days ago and I was wondering when the project plans to move to Java 7.
> >
> > In the POM, the maven compiler plugin is set to Java 6.
> >
> > For the 1.4 release, it would be nice for us to move to the latest
> version
> > of Java that will continue to have security updates.
> >
> > After February 2013, Oracle will no longer post updates of Java SE 6 to
> its
> > public download sites. All Java 6 releases up to and including 6u43 will
> be
> > moved to the Java Archive on the Oracle Technology Network, where they
> will
> > remain available but not receive updates. Oracle recommends that users
> > migrate to Java 7 in order to continue receiving public updates and
> > security enhancements.
> >
> > References
> > http://java.com/en/download/faq/java_6.xml
> > http://www.oracle.com/technetwork/java/eol-135779.html
>