Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> Re: How to run HBase tests against 0.94? (seems to be for and old version of HBase)


Copy link to this message
-
Re: How to run HBase tests against 0.94? (seems to be for and old version of HBase)
>From what I see in 0.94 and in the jira, it should work, there is nothing
fancy there.

moving to dev list btw, user in bcc.
On Wed, Jan 2, 2013 at 6:15 PM, Nicolas Liochon <[EMAIL PROTECTED]> wrote:

> If it works, it's ok: it's not going to give you wrong results. Just that
> it adds nothing to a plain mvn test.
> So if it worked for you on this patch, then you're done :-).
>
> This should be enough most most cases:
> mvn test
>
> If you want to play it safe, you will run all the tests before sending the
> patch.
> That's mvn test -P runAllTests
>
> And this should work. If you have a strange error, you can clean the env
> with a mvn clean install -DskipTests.
>
> 'P runAllTests' adds some extra tests and increases the parallelization,
> but does not change the environment.
>
>
> I'm gonna have a look at the JIRA you're working on to see if there
> something that could explain the issue you're having.
>
>
>  On Wed, Jan 2, 2013 at 6:03 PM, Jean-Marc Spaggiari <
> [EMAIL PROTECTED]> wrote:
>
>> for my code validation? What's the right way to run the tests on 0.94?
>
>
>
+
Jean-Marc Spaggiari 2013-01-02, 17:48
+
Jean-Marc Spaggiari 2013-01-03, 16:53