Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop, mail # dev - very old dependencies


Copy link to this message
-
Re: very old dependencies
Andrew Wang 2014-03-29, 02:42
We've successfully supported CDH4.2+ on Java 7 as well as CDH5, so I think
that code wise we're ready to move to 7. However, we can't start using Java
7-only features in the 2.x line for compatibility reasons.

Also, even if the compatibility guidelines state that we can bump our
dependencies whenever we want, practically speaking we can't in the 2.x
line without breaking existing applications. I think the best we can do is
fix this for 3.x by shading everything so we don't hit this issue again.

Andrew
On Fri, Mar 28, 2014 at 5:34 PM, Colin McCabe <[EMAIL PROTECTED]>wrote: