Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
MapReduce >> mail # user >> Re: about replication


+
Irfan Sayed 2013-08-06, 06:50
+
manish dunani 2013-08-06, 07:10
+
Irfan Sayed 2013-08-05, 06:53
+
Mohammad Tariq 2013-08-05, 09:33
+
Irfan Sayed 2013-08-05, 11:16
+
Mohammad Tariq 2013-08-05, 11:48
+
Irfan Sayed 2013-08-05, 11:59
+
manish dunani 2013-08-05, 12:30
+
Irfan Sayed 2013-08-06, 04:59
+
manish dunani 2013-08-06, 06:10
+
Mohammad Tariq 2013-08-06, 20:22
+
Mohammad Tariq 2013-08-06, 11:49
+
Irfan Sayed 2013-08-06, 11:56
+
Mohammad Tariq 2013-08-06, 12:00
+
Irfan Sayed 2013-08-20, 09:26
+
Mohammad Tariq 2013-08-20, 09:53
+
Irfan Sayed 2013-08-20, 10:44
+
Mohammad Tariq 2013-08-21, 11:58
+
Irfan Sayed 2013-08-22, 04:22
+
Arpit Agarwal 2013-08-22, 04:29
+
Irfan Sayed 2013-08-22, 05:05
+
Arpit Agarwal 2013-08-22, 05:56
+
Irfan Sayed 2013-08-22, 06:19
+
Irfan Sayed 2013-08-22, 11:31
Copy link to this message
-
Re: about replication
It is possible. Theoretically Hadoop doesn't stop you from doing that. But
it is not a very wise setup.

Warm Regards,
Tariq
cloudfront.blogspot.com
On Thu, Aug 22, 2013 at 5:01 PM, Irfan Sayed <[EMAIL PROTECTED]> wrote:

> please suggest
>
> regards
> irfan
>
>
>
> On Thu, Aug 22, 2013 at 11:49 AM, Irfan Sayed <[EMAIL PROTECTED]>wrote:
>
>> thanks.
>> can i have setup like this :
>> namenode will be on linux (flavour may be RHEL, CentOS, UBuntu etc)
>> and datanodes are the combination of any OS (windows , linux , unix etc )
>>
>> however, my doubt is,  as the file systems of  both the systems (win and
>> linux ) are different ,  datanodes of these systems can not be part of
>> single cluster . i have to make windows cluster separate and UNIX cluster
>> separate ?
>>
>> regards
>>
>>
>>
>> On Thu, Aug 22, 2013 at 11:26 AM, Arpit Agarwal <[EMAIL PROTECTED]
>> > wrote:
>>
>>> I just noticed you are on Cygwin. IIRC Windows PIDs are not the same as
>>> Cygwin PIDs so that may be causing the discrepancy. I don't know how well
>>> Hadoop works in Cygwin as I have never tried it. Work is in progress for
>>> native Windows support however there are no official releases with Windows
>>> support yet. It may be easier to get familiar with a release<https://www.apache.org/dyn/closer.cgi/hadoop/common/>on Linux if you are new to it.
>>>
>>>
>>>
>>> On Wed, Aug 21, 2013 at 10:05 PM, Irfan Sayed <[EMAIL PROTECTED]>wrote:
>>>
>>>> thanks
>>>> here is what i did .
>>>> i stopped all the namenodes and datanodes using ./stop-dfs.sh command
>>>> then deleted all pid files for namenodes and datanodes
>>>>
>>>> started dfs again with command : "./start-dfs.sh"
>>>>
>>>> when i ran the "Jps" command . it shows
>>>>
>>>> Administrator@DFS-DC /cygdrive/c/Java/jdk1.7.0_25/bin
>>>> $ ./jps.exe
>>>> 4536 Jps
>>>> 2076 NameNode
>>>>
>>>> however, when i open the pid file for namenode then it is not showing
>>>> pid as : 4560. on the contrary, it shud show : 2076
>>>>
>>>> please suggest
>>>>
>>>> regards
>>>>
>>>>
>>>>
>>>> On Thu, Aug 22, 2013 at 9:59 AM, Arpit Agarwal <
>>>> [EMAIL PROTECTED]> wrote:
>>>>
>>>>> Most likely there is a stale pid file. Something like
>>>>> \tmp\hadoop-*datanode.pid. You could try deleting it and then restarting
>>>>> the datanode.
>>>>>
>>>>> I haven't read the entire thread so you may have looked at this
>>>>> already.
>>>>>
>>>>> -Arpit
>>>>>
>>>>>
>>>>>
>>>>> On Wed, Aug 21, 2013 at 9:22 PM, Irfan Sayed <[EMAIL PROTECTED]>wrote:
>>>>>
>>>>>> datanode is trying to connect to namenode continuously but fails
>>>>>>
>>>>>> when i try to run "jps" command it says :
>>>>>> $ ./jps.exe
>>>>>> 4584 NameNode
>>>>>> 4016 Jps
>>>>>>
>>>>>> and when i ran the "./start-dfs.sh" then it says :
>>>>>>
>>>>>> $ ./start-dfs.sh
>>>>>> namenode running as process 3544. Stop it first.
>>>>>> DFS-1: datanode running as process 4076. Stop it first.
>>>>>> localhost: secondarynamenode running as process 4792. Stop it first.
>>>>>>
>>>>>> both these logs are contradictory
>>>>>> please find the attached logs
>>>>>>
>>>>>> should i attach the conf files as well ?
>>>>>>
>>>>>> regards
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Wed, Aug 21, 2013 at 5:28 PM, Mohammad Tariq <[EMAIL PROTECTED]>wrote:
>>>>>>
>>>>>>> Your DN is still not running. Showing me the logs would be helpful.
>>>>>>>
>>>>>>> Warm Regards,
>>>>>>> Tariq
>>>>>>> cloudfront.blogspot.com
>>>>>>>
>>>>>>>
>>>>>>> On Wed, Aug 21, 2013 at 5:11 PM, Irfan Sayed <[EMAIL PROTECTED]>wrote:
>>>>>>>
>>>>>>>> i followed the url and did the steps mention in that. i have
>>>>>>>> deployed on the windows platform
>>>>>>>>
>>>>>>>> Now, i am able to browse url : http://localhost:50070 (name node )
>>>>>>>> however, not able to browse url : http://localhost:50030
>>>>>>>>
>>>>>>>> please refer below
>>>>>>>>
>>>>>>>> [image: Inline image 1]
>>>>>>>>
>>>>>>>> i have modified all the config files as mentioned and formatted the
>>>>>>>> hdfs file system as well
>>>>>>>> please suggest
+
Irfan Sayed 2013-08-23, 04:15
+
Olivier Renault 2013-08-23, 07:27
+
Irfan Sayed 2013-08-23, 09:54
+
Olivier Renault 2013-08-23, 10:40
+
Olivier Renault 2013-09-03, 07:28
+
Irfan Sayed 2013-09-05, 10:33
+
Olivier Renault 2013-09-05, 12:39
+
Irfan Sayed 2013-09-10, 06:02
+
Olivier Renault 2013-09-10, 11:39
+
Irfan Sayed 2013-09-11, 09:26
+
Olivier Renault 2013-09-11, 09:46
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB