Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper, mail # user - upgrading zookeeper from 3.4.3


Copy link to this message
-
Re: upgrading zookeeper from 3.4.3
Nagendra Prasath 2014-01-11, 00:53
Hi Patrick,
I downloaded zookeeper 3.4.3 and complied using 'ant rpm' and then
installed the rpm like
yum  --disablerepo=* *install* <zookeeper 3.4.3 rpm>

 and then upgraded to zookeeper 3.4.5 like
yum --disablerepo=* *update* <zookeeper 3.4.5 rpm>
Regards,
Nagendra Prasath

On Fri, Jan 10, 2014 at 1:09 PM, Patrick Hunt [via zookeeper-user] <
ml-node+[EMAIL PROTECTED]> wrote:

> How did you install?
>
> Patrick
>
> On Thu, Jan 9, 2014 at 12:18 PM, Nagendra Prasath
> <[hidden email] <http://user/SendEmail.jtp?type=node&node=7579487&i=0>>
> wrote:
>
> > I'm upgrading from 3.4.3 -> 3.4.5. When zookeeper service is started, it
> > couldnt get the location of cfg file.
> >
> > [root@centos 3.4.5]# service zookeeper start
> > Starting ZooKeeper daemon (zookeeper): JMX enabled by default
> > Using config: /usr/sbin/../etc/zookeeper/zoo.cfg
> > grep: /usr/sbin/../etc/zookeeper/zoo.cfg: No such file or directory
> > mkdir: cannot create directory `': No such file or directory
> > Starting zookeeper ... /usr/sbin/zkServer.sh: line 113:
> > /zookeeper_server.pid: Permission denied
> >
> > Seems the symlink /usr/etc/zookeeper is removed by
> update-zookeeper-env.sh
> > during cleanup (3.4.3) phase of upgrade process.
> >
> > I couldnt see any post on this, probably its my env is the issue....?
> >
> >
> >
> >
> >
> > --
> > View this message in context:
> http://zookeeper-user.578899.n2.nabble.com/upgrading-zookeeper-from-3-4-3-tp7579472.html
> > Sent from the zookeeper-user mailing list archive at Nabble.com.
>
>
> ------------------------------
>  If you reply to this email, your message will be added to the discussion
> below:
>
> http://zookeeper-user.578899.n2.nabble.com/upgrading-zookeeper-from-3-4-3-tp7579472p7579487.html
>  To unsubscribe from upgrading zookeeper from 3.4.3, click here<http://zookeeper-user.578899.n2.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=7579472&code=bmFnZW5kcmEucHJhc2F0aEBnbWFpbC5jb218NzU3OTQ3MnwtMTU2MzU1MjM1MA==>
> .
> NAML<http://zookeeper-user.578899.n2.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>

--
Thanks,
Nagendra Prasath M P
--
View this message in context: http://zookeeper-user.578899.n2.nabble.com/upgrading-zookeeper-from-3-4-3-tp7579472p7579489.html
Sent from the zookeeper-user mailing list archive at Nabble.com.