Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HDFS, mail # user - secure hadoop datanode start problem


Copy link to this message
-
Re: secure hadoop datanode start problem
Harsh J 2012-06-24, 13:18
Hi Farrokh,

Moving this to [EMAIL PROTECTED] as it is a CDH4 specific
question. I've bcc'd hdfs-user@ and cc'd you in case you aren't
subscribed to cdh-user
(http://groups.google.com/a/cloudera.org/group/cdh-user/).

What OS packages of CDH4 are you using? And how exactly are you
attempting to start your DN? Do you simply do "sudo service
hadoop-hdfs-datanode start" and get this?

On Sun, Jun 24, 2012 at 4:32 PM, Farrokh Shahriari
<[EMAIL PROTECTED]> wrote:
> Hello
>
> I want to configure my hadoop cluster to work with kerberos. I've followed
> the cdh4 security guideline in the cloudera website. After a lot of
> problems, I was finally able to start the namenode without any problems.
> Now when I want to start the datanode, I get the following error:
>
> ERROR datanode.DataNode: Exception in secureMain
> java.lang.RuntimeException: Cannot start secure cluster without privileged
> resources.
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.startDataNode(DataNode.java:641)
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.<init>(DataNode.java:296)
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.makeInstance(DataNode.java:1590)
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:1523)
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.createDataNode(DataNode.java:1546)
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.secureMain(DataNode.java:1700)
>         at
> org.apache.hadoop.hdfs.server.datanode.DataNode.main(DataNode.java:1717)
> 12/06/24 15:27:34 INFO datanode.DataNode: SHUTDOWN_MSG:
>
> What's the problem? I've searched a bit, and some have said that this is
> because the security packages of hadoop aren't installed, but I've installed
> cdh4 completely.
>
> Thanks
>

--
Harsh J