Hi

We are using 0.8.1.1 for producer, broker(cluster) as well as for storm
integration.

We are planning to upgrade it to 0.10.0 the main reason being producer API
supporting flush().

That said, we have test it in QA and look like as long as protocol is not
bumped with newer dependencies, roll back is possible and it can go back to
0.8.1.1.

Just to confirm, can some expert second that ?

On the other hand the documentation mentions

*"Note:* Bumping the protocol version and restarting can be done any time
after the brokers were upgraded. It does not have to be immediately after."

So is it a good idea to change dependancies to 0.10.0 and keep the protocol
0.8.0 ?

What are advantages of using 0.10.0 protocol ?
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB