So,

It looks like there is an issue with using snappy version 1.0.4.1, with
java 7, on MacOSX, which is fixed in version 1.0.5.  We've verified this.

https://github.com/ptaoussanis/carmine/issues/5

Perhaps 1.0.5 should be the default for kafka 0.8 (or maybe too late for
that?).

I've filed:  https://issues.apache.org/jira/browse/KAFKA-1164

 
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB