Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # dev - Building trunk


Copy link to this message
-
Building trunk
Jean-Marc Spaggiari 2013-03-20, 21:12
Is there anything I'm nissing to build the trunk? I followed the steps
on the online book, but I'm still facing some issues.

I have extracted a clean SVN trunk, was able to pass mvn package -DskipTests
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 31.181s
[INFO] Finished at: Wed Mar 20 17:06:58 EDT 2013
[INFO] Final Memory: 39M/797M
[INFO] ------------------------------------------------------------------------
But assembly is not working MAVEN_OPTS="-Xmx10g" mvn clean site
install assembly:assembly -DskipTests -Prelease

[INFO] ------------------------------------------------------------------------
[INFO] Skipping HBase
[INFO] This project has been banned from the build due to previous failures.
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] HBase ............................................. FAILURE [25.888s]
[INFO] HBase - Common .................................... SKIPPED
[INFO] HBase - Protocol .................................. SKIPPED
[INFO] HBase - Client .................................... SKIPPED
[INFO] HBase - Prefix Tree ............................... SKIPPED
[INFO] HBase - Hadoop Compatibility ...................... SKIPPED
[INFO] HBase - Hadoop One Compatibility .................. SKIPPED
[INFO] HBase - Server .................................... SKIPPED
[INFO] HBase - Integration Tests ......................... SKIPPED
[INFO] HBase - Examples .................................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 26.813s
[INFO] Finished at: Wed Mar 20 17:11:45 EDT 2013
[INFO] Final Memory: 69M/1676M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project hbase-server: Could not
resolve dependencies for project
org.apache.hbase:hbase-server:jar:0.97-SNAPSHOT: The following
artifacts could not be resolved:
org.apache.hbase:hbase-common:jar:0.97-SNAPSHOT,
org.apache.hbase:hbase-protocol:jar:0.97-SNAPSHOT,
org.apache.hbase:hbase-client:jar:0.97-SNAPSHOT,
org.apache.hbase:hbase-prefix-tree:jar:0.97-SNAPSHOT,
org.apache.hbase:hbase-common:jar:tests:0.97-SNAPSHOT,
org.apache.hbase:hbase-hadoop-compat:jar:0.97-SNAPSHOT,
org.apache.hbase:hbase-hadoop-compat:jar:tests:0.97-SNAPSHOT,
org.apache.hbase:hbase-hadoop1-compat:jar:0.97-SNAPSHOT,
org.apache.hbase:hbase-hadoop1-compat:jar:tests:0.97-SNAPSHOT: Failure
to find org.apache.hbase:hbase-common:jar:0.97-SNAPSHOT in
http://repository-netty.forge.cloudbees.com/snapshot/ was cached in
the local repository, resolution will not be reattempted until the
update interval of cloudbees netty has elapsed or updates are forced
-> [Help 1]
[ERROR]

What did I wrong?

Thanks,

JM