Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> Is there an accumulo faq?


Copy link to this message
-
Re: Is there an accumulo faq?
Is everyone using the version of maven?  It can be frustrating to reconcile
differences if not.  Is there a recommended version of maven for doing
Accumulo development?

On Mon, Mar 5, 2012 at 10:51 AM, John Vines <[EMAIL PROTECTED]> wrote:

> So with a regular checkout, I was able to run pmd:pmd just fine, without
> installing anything. Do you know what could be causing this?
>
> John
>
> On Sun, Mar 4, 2012 at 10:23 PM, David Medinets <[EMAIL PROTECTED]
> >wrote:
>
> > In the parent pom.xml, these lines exist:
> >
> >      <plugin>
> >        <groupId>org.apache.maven.plugins</groupId>
> >        <artifactId>maven-pmd-plugin</artifactId>
> >        <version>2.4</version>
> >        <configuration>
> >          <format>html</format>
> >          <includeTests>true</includeTests>
> >          <targetJdk>1.6</targetJdk>
> >        </configuration>
> >      </plugin>
> >
> > Therefore PMD is already supported in Accumulo's build process.
> >
> > On Sun, Mar 4, 2012 at 9:41 PM, John Vines <[EMAIL PROTECTED]>
> wrote:
> > > I am not familiar with this pmd module. A cursory glance over things
> > makes
> > > it seem like it's for documenting our procedures, but why should we be
> > > concerned with a module we don't use being broken?
> > >
> > > John
> > >
> > > On Sun, Mar 4, 2012 at 9:22 PM, David Medinets <
> [EMAIL PROTECTED]
> > >wrote:
> > >
> > >> I am seeing this warning when running 'mvn pmd:pmd':
> > >>
> > >>  The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is missing,
> > >> no dependency information available
> > >>
> > >> I was able to eliminate this message using a project on github:
> > >>
> > >> git clone git://
> > >> github.com/mfriedenhagen/dummy-lifecycle-mapping-plugin.git
> > >> cd dummy-lifecycle-mapping-plugin
> > >> mvn install
> > >>
> > >> This is a minor issue, but it might be nice to add the fix to an FAQ.
> > >>
> >
>