Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> premature exit in patch testing


+
Ted Yu 2012-12-28, 03:04
+
Enis Söztutar 2012-12-28, 03:12
+
Nicolas Liochon 2012-12-28, 07:54
+
Ted Yu 2012-12-28, 14:38
+
Nicolas Liochon 2012-12-28, 15:12
Copy link to this message
-
Re: premature exit in patch testing
It turned out to be environment issue on hadoop9 and hadoop8.

I have narrowed machine selection for Hadoop QA

Thanks

On Friday, December 28, 2012, Nicolas Liochon wrote:

> Ok, I tried on another machine with the 3.0.3 installed, I got the $? == 0
> as well so it seems that it's something that is not reproducible on all
> computers...
>
>
>
>
>
> On Fri, Dec 28, 2012 at 3:38 PM, Ted Yu <[EMAIL PROTECTED]<javascript:;>>
> wrote:
>
> > I was using:
> > Apache Maven 3.0.3 (r1075438; 2011-02-28 09:31:09-0800)
> >
> > I think the $? should be logged by test-patch.sh so that we can
> understand
> > what happened on hadoopx.
> >
> > One other enhancement is to log the name of machine where the test suite
> > runs. This would be useful to identify faulty server where several tests
> > encountered OOME.
> >
> > Cheers
> >
> > On Thu, Dec 27, 2012 at 11:54 PM, Nicolas Liochon <[EMAIL PROTECTED]<javascript:;>
> >
> > wrote:
> >
> > > What's your maven version?
> > > I tried locally, with maven 3.0.4, $? is 0
> > > I had a go on maven bugs, but I didn't find anything related.
> > >
> > >
> > > On Fri, Dec 28, 2012 at 4:12 AM, Enis Söztutar <[EMAIL PROTECTED]<javascript:;>
> >
> > wrote:
> > >
> > > > Do you know why maven returned 1? It seems that the build was
> > successful.
> > > >
> > > > On Thu, Dec 27, 2012 at 7:04 PM, Ted Yu <[EMAIL PROTECTED]<javascript:;>>
> wrote:
> > > >
> > > > > should
> > > >
> > >
> >
>