Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # user >> http://repo1.maven.org/maven2/junit/junit/3.8.1/junit-3.8.1.pom: invalid sha1:


Copy link to this message
-
Re: http://repo1.maven.org/maven2/junit/junit/3.8.1/junit-3.8.1.pom: invalid sha1:
Hi ,
I did that already and it is now working ... I removed the entire ivy2
(~/.ivy2/* ) directory
(My ivy folder is .ivy2 and not .ivy .. Any problem with this ?)

Now I am getting more errors (as I have cleaned the entire cache) as follows..
Any problem with the ivy/ant version ? ( I read in some forums abt the
related errors)

My ant version is 1.7.0 ..
------------------------------------------ERROR-------------------------------------------------------

clover:
proxy.setup:
ivy-download:
      [get] Getting:
http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.0.0-rc2/ivy-2.0.0-rc2.jar
      [get] To: /home/rip/workspace/hadoop/ivy/ivy-2.0.0-rc2.jar
      [get] Not modified - so not downloaded
ivy-init-dirs:
ivy-probe-antlib:
ivy-init-antlib:
ivy-init:
[ivy:configure] :: Ivy 2.0.0-rc2 - 20081028224207 ::
http://ant.apache.org/ivy/ ::
:: loading settings :: file = /home/rip/workspace/hadoop/ivy/ivysettings.xml
ivy-resolve-common:
[ivy:resolve] :: resolving dependencies ::
org.apache.hadoop#Hadoop;working@Cloud
[ivy:resolve] confs: [common]
[ivy:resolve] found log4j#log4j;1.2.15 in maven2
[ivy:resolve] found xmlenc#xmlenc;0.52 in maven2
[ivy:resolve] found net.java.dev.jets3t#jets3t;0.6.1 in maven2
[ivy:resolve] found commons-net#commons-net;1.4.1 in maven2
[ivy:resolve] found org.mortbay.jetty#servlet-api-2.5;6.1.14 in maven2
[ivy:resolve] found org.mortbay.jetty#jetty;6.1.14 in maven2
[ivy:resolve] found org.mortbay.jetty#jetty-util;6.1.14 in maven2
[ivy:resolve] found tomcat#jasper-runtime;5.5.12 in maven2
[ivy:resolve] found tomcat#jasper-compiler;5.5.12 in maven2
[ivy:resolve] found commons-el#commons-el;1.0 in maven2
[ivy:resolve] found org.slf4j#slf4j-api;1.4.3 in maven2
[ivy:resolve] found org.eclipse.jdt#core;3.1.1 in maven2
[ivy:resolve] found org.slf4j#slf4j-log4j12;1.4.3 in maven2
[ivy:resolve] :: resolution report :: resolve 1236ms :: artifacts dl 43ms
---------------------------------------------------------------------
|                  |            modules            ||   artifacts   |
|       conf       | number| search|dwnlded|evicted|| number|dwnlded|
---------------------------------------------------------------------
|      common      |   19  |   0   |   0   |   0   ||   13  |   0   |
---------------------------------------------------------------------
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve] problem while downloading module descriptor:
http://repo1.maven.org/maven2/commons-logging/commons-logging/1.0.4/commons-logging-1.0.4.pom:
invalid sha1: expected=�

===================================================================

On Sun, Oct 31, 2010 at 12:06 PM, Konstantin Boudnik <[EMAIL PROTECTED]> wrote:
> You can at least try to clean you local Ivy cache for junit artifacts
> (i.e. rm -rf ~/.ivy/junit*). That'd be a pretty reasonable first step.
>
> On Sun, Oct 31, 2010 at 11:33AM, bharath v wrote:
>> Hi ,
>>
>>
>> Thanks for your reply .
>>
>> I am using had-0.20.0 . I am new to ivy thingy .. So is there any
>> solution to this ?
>>
>> Thanks
>>
>>
>> On Sun, Oct 31, 2010 at 3:42 AM, Konstantin Boudnik <[EMAIL PROTECTED]> wrote:
>> > I assume you're trying to build 0.20+. Later projects uses later version of
>> > junit... Running the build...
>> >
>> > [ivy:resolve] downloading http://repo1.maven.org/maven2/junit/junit/3.8.1/junit-3.8.1.jar ...
>> > [ivy:resolve] .................................................................................... (118kB)
>> > [ivy:resolve] .. (0kB)
>> > [ivy:resolve] ═ [SUCCESSFUL ] junit#junit;3.8.1!junit.jar (1486ms)
>> >
>> > Looks like your ivy cache is hosed or something similar.
>> > ═Cos
>> >
>> > On Sat, Oct 30, 2010 at 06:43PM, bharath v wrote:
>> >> Hi ,
>> >>
>> >> I am getting the error
>> >>
>> >> http://repo1.maven.org/maven2/junit/junit/3.8.1/junit-3.8.1.pom:
>> >> invalid sha1: ═..
>> >>
>> >> Is it downloading the corrupt file or is there any other thing which I
>> >> need to take care of ??
>> >>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB