Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Drill >> mail # dev >> Trying to get started....


Copy link to this message
-
Re: Trying to get started....
Thanks both Tim and J! It now compiles from within Intellij as well!

On Sun, Jun 30, 2013 at 10:53 PM, Jacques Nadeau <[EMAIL PROTECTED]> wrote:

> Just remove the log-synth module from the intellij project.  It is in
> the prototype directory structure but isn't a referenced submodule of
> the compile tree.
>
> J
>
> On Sun, Jun 30, 2013 at 10:15 AM, Timothy Chen <[EMAIL PROTECTED]> wrote:
> > Hi Srihari,
> >
> > I think you just need to choose sandbox/prototype as root folder to
> import. You won't need log-synth and I think it hasn't been touched for a
> long time.
> >
> > Tim
> >
> > Sent from my iPhone
> >
> > On Jun 30, 2013, at 9:54 AM, Srihari Srinivasan <
> [EMAIL PROTECTED]> wrote:
> >
> >> I had to include the missed generated-sources directory manually to get
> it
> >> to recognize generated sources. It could be an issue with Idea 11. Its
> >> known to be a bit buggy with mvn project imports.
> >>
> >> Hopefully the last question. I am getting a dependency not met message
> >> within Idea for the mahout-math-0.8-snapshot jar. This is in the
> log-synth
> >> module.
> >>
> >> -- Hari
> >>
> >>
> >> On Sun, Jun 30, 2013 at 9:22 PM, Timothy Chen <[EMAIL PROTECTED]>
> wrote:
> >>
> >>> Alternatively you can try right clicking on the maven tab in Intelllij
> and
> >>> manually run generate sources on java-exec module.
> >>>
> >>> That might make the errors go away, if not then try maven compile.
> >>>
> >>> Tim
> >>>
> >>>
> >>> On Sun, Jun 30, 2013 at 8:36 AM, Jacques Nadeau <[EMAIL PROTECTED]>
> >>> wrote:
> >>>
> >>>> I believe you need to run a full cli compile once before importing,
> >>>> otherwise intellij doesn't detect all paths correctly.
> >>>> On Jun 30, 2013 8:34 AM, "Srihari Srinivasan" <
> [EMAIL PROTECTED]
> >>>>
> >>>> wrote:
> >>>>
> >>>>> Just one last hitch with my IntelliJ set up. I created a project in
> >>> Idea
> >>>>> using the option that reads the mvn model to create the project
> >>>> structure.
> >>>>>
> >>>>> Across the board the IDE complains about not finding the sources for
> >>>>> "org.apache.drill.exec.proto.**Protos" files. I realize that these
> are
> >>>>> generated sources which are kept under the target/generated-sources
> dir
> >>>> of
> >>>>> the java-exec module. The IDE is not able to find them or link to the
> >>> jar
> >>>>> file that perhaps compiles them. The command line build went through
> >>>>> successfully.
> >>>>>
> >>>>> Is anyone using IntelliJ to develop?
> >>>>>
> >>>>> -- Hari
> >>>>>
> >>>>> On Sun, Jun 30, 2013 at 8:06 PM, Srihari Srinivasan <
> >>>>> [EMAIL PROTECTED]> wrote:
> >>>>>
> >>>>>> Thanks! That worked.
> >>>>>>
> >>>>>>
> >>>>>> On Sun, Jun 30, 2013 at 6:19 PM, Jacques Nadeau <[EMAIL PROTECTED]
> >>>>>> wrote:
> >>>>>>
> >>>>>>> You actually need 2.5.x, not 2.4.x.  The compile errors are due to
> >>>> that.
> >>>>>>>
> >>>>>>> J
> >>>>>>> On Jun 30, 2013 1:36 AM, "Azuryy Yu" <[EMAIL PROTECTED]> wrote:
> >>>>>>>
> >>>>>>>> and you'd better install protobuf-2.4.x,  not 2.5!
> >>>>>>>>
> >>>>>>>> --Send from my Sony mobile.
> >>>>>>>> On Jun 30, 2013 2:49 PM, "Philip Haynes" <
> >>>>>>>> [EMAIL PROTECTED]>
> >>>>>>>> wrote:
> >>>>>>>>
> >>>>>>>>> Srihari -
> >>>>>>>>>
> >>>>>>>>>> java.io.IOException: *Cannot run program "protoc" (in
> >>> directory
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> Maven is telling you that you need to install protocol buffers
> >>>> which
> >>>>>>> you
> >>>>>>>>> can find here
> >>>>>>>>> http://code.google.com/p/protobuf/
> >>>>>>>>>
> >>>>>>>>> On 30/06/13 4:44 PM, "Srihari Srinivasan" <
> >>>>> [EMAIL PROTECTED]>
> >>>>>>>>> wrote:
> >>>>>>>>>
> >>>>>>>>>> When I try to do mvn install on the execwork branch this is the
> >>>>>>> error I
> >>>>>>>>>> get
> >>>>>>>>>> -
> >>>>>>>>>>
> >>>>>>>>>> [ERROR] Failed to execute goal
> >>>>>>>>>> org.apache.maven.plugins:maven-antrun-plugin:1.6:run
> >>>>>>> (generate-sources)
> >>>>>>>> on
> >>>>>>>>>> project java-exec: An Ant BuildException has occured: Execute
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB