Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Hadoop >> mail # user >> Conflicting dependency versions


Copy link to this message
-
Conflicting dependency versions
Hi,

I have a yarn application that launches a mapreduce job that has a mapper
that uses a newer version of guava than the one hadoop is using.  Because
of this, the mapper fails and gets a NoSuchMethod exception.  Is there a
way to indicate that application dependencies should be used over hadoop
dependencies?

Thanks,
Albert
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB