Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop, mail # user - Conflicting dependency versions


Copy link to this message
-
Conflicting dependency versions
Albert Shau 2013-10-10, 22:27
Hi,

I have a yarn application that launches a mapreduce job that has a mapper
that uses a newer version of guava than the one hadoop is using.  Because
of this, the mapper fails and gets a NoSuchMethod exception.  Is there a
way to indicate that application dependencies should be used over hadoop
dependencies?

Thanks,
Albert