Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper >> mail # user >> How to Build ZooKeeper


Copy link to this message
-
Re: How to Build ZooKeeper
Hi David -

I'm having trouble locating the version of the file that you're seeing. I
downloaded the 3.3.5 tarball and don't see that construct in
CommitProcessor.java, nor do I see it in the trunk version of the file or
the current 3.3 branch. I'd like to track it down so that we can fix it if
we need to! Can you share exactly which branch you are on in SVN, and the
last commit in that branch?

Thanks,
Henry

On 17 July 2012 11:30, David Nickerson <
[EMAIL PROTECTED]> wrote:

> In the configuration for the build.xml file, I added the JRE VM argument
> -ant.build.javac.source="1.5", and got this result:
>
>     [javac] Compiling 13 source files to
> C:\Users\dnickerson\workspace\ZooKeeper-3.3.5\build\classes
>     [javac] warning: [options] bootstrap class path not set in conjunction
> with -source 1.5
>     [javac]
>
> C:\Users\dnickerson\workspace\ZooKeeper-3.3.5\src\java\main\org\apache\zookeeper\server\quorum\CommitProcessor.java:155:
> error: multi-catch statement is not supported in -source 1.5
>     [javac]         } catch (InterruptedException |
> RequestProcessorException ex) {
>     [javac]                                       ^
>     [javac]   (use -source 7 or higher to enable multi-catch statement)
>     [javac] 1 error
>     [javac] 1 warning
>
> I really don't understand how ZooKeeper uses Java 7 features and expects to
> target Java 1.5.
>
> On Tue, Jul 17, 2012 at 12:42 PM, David Nickerson <
> [EMAIL PROTECTED]> wrote:
>
> > It would appear that any link to imgur (a simple image hosting site)
> > causes the spam filter to automatically mark the e-mail as spam.
> >
> > I have seven screen shots that show the ANT script configuration, Eclipse
> > configuration, and the ZooKeeper project settings. They're at imgur
> > .com/a/HLAij#0, just remove the space after 'imgur'. Be sure to check the
> > window titles to see which component the settings are for.
> >
> > Any idea what I'm doing wrong?
> >
> > On Tue, Jul 17, 2012 at 12:31 PM, David Nickerson <
> > [EMAIL PROTECTED]> wrote:
> >
> >> I have a scenario in which I need to run an embedded ZooKeeper server.
> >> (For customer convenience, mostly.) However, if the ZooKeeper server
> fails,
> >> it shouldn't call System.exit. There is a patch, but it has not been
> >> committed. <https://issues.apache.org/jira/browse/ZOOKEEPER-575> I plan
> >> to use the patch for reference and modify ZooKeeper 3.3.5.
> >>
> >> I got the source code of ZooKeeper 3.3.5 using SVN and Eclipse, I
> >> selected the output folder as something other than 'bin', and I ran the
> >> build script with the targets compile, compile-test, and eclipse.The
> >> build fails and gives this output. <http://pastebin.com/wFERRWiJ>
> >>
> >> I'm not sure whether it's failing because it's trying to
> >> execute workspace\ZooKeeper or because the "target release 1.5 conflicts
> >> with default source release 1.7".
> >>
> >> I will post a link showing my configuration in a second e-mail. I had to
> >> reduce the number of links to get past the spam filter.
> >>
> >
> >
>

--
Henry Robinson
Software Engineer
Cloudera
415-994-6679