Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # dev - Releasing 1.5


+
John Vines 2013-04-25, 17:48
+
Keith Turner 2013-04-25, 17:56
+
John Vines 2013-04-25, 18:03
+
Keith Turner 2013-04-25, 18:09
+
Christopher 2013-04-25, 18:32
+
John Vines 2013-04-25, 18:54
+
Keith Turner 2013-04-25, 19:32
+
Josh Elser 2013-04-25, 19:37
+
John Vines 2013-04-25, 19:46
+
Keith Turner 2013-04-25, 19:57
+
Josh Elser 2013-04-25, 20:06
+
Keith Turner 2013-04-25, 20:30
+
Benson Margulies 2013-04-25, 20:41
+
Keith Turner 2013-04-26, 12:42
+
David Medinets 2013-04-26, 19:32
+
Billie Rinaldi 2013-04-26, 20:19
+
John Vines 2013-04-26, 20:35
+
Billie Rinaldi 2013-04-26, 21:47
Copy link to this message
-
Re: Releasing 1.5
Christopher 2013-04-26, 23:24
John, the preferred naming convention, is to use classifiers (maven
terminology), which results in file names such as:
<artifactId>-<version>-<classifier>.jar; but this is best done as a
conscious decision to produce multiple variants of the same artifact.
It doesn't work that well in Maven when you have to recompile the same
artifacts.

In RPM, the convention is to use the "release" portion of the package
name, which identifies the versioning of the packaging (vs. the
versioning of the source): <artifact>-<version>-<release>.<arch>.rpm ;
(example"subversion-1.6.11-9.el6_4.x86_64.rpm" or
"subversion-1.7.8-3.fc18.i686.rpm"). These are almost always
customized packaging that diverge from upstream's official release in
some way (file paths, default configuration, recompiled with different
options, etc.).

So, I think one set of build artifacts is sufficient... at least for
the purposes of getting through a vote.
--
Christopher L Tubbs II
http://gravatar.com/ctubbsii
On Fri, Apr 26, 2013 at 4:35 PM, John Vines <[EMAIL PROTECTED]> wrote:
> I had issues running a hadoop2 compiled version of accumulo against CDH4, I
> can't remember the specifics of it though.
>
>
> When I said specialized packaging, I was thinking of a naming convention to
> distinguish hadoop1 vs. hadoop2 ( vs. vendor-specific hadoop) compiled jars.
>
>
> On Fri, Apr 26, 2013 at 4:19 PM, Billie Rinaldi <[EMAIL PROTECTED]>wrote:
>
>> I'm not sure we are talking about actual vendor-specific code.  We are
>> deciding whether or not to create additional release tarballs that have
>> been compiled against various vendors' Hadoop-compatible file systems.
>> Assuming that we determine there is nothing prohibiting us from doing this,
>> I think it would simply be up to the release manager (i.e. anyone who
>> assembles a release and calls a vote for it).  If someone cares enough
>> about a particular distribution to build and create an extra tarball, they
>> can.  However, I don't think this is common for Apache projects --
>> additional packaging is usually left to supporting companies.  I haven't
>> even noticed any releases yet that come in Hadoop 1 and Hadoop 2 flavors.
>>
>> I haven't heard (until now) that Accumulo compiled against an appropriate
>> version of Apache Hadoop will not work with CDH, but John says that's the
>> case.  John, have you tried this?  Also, what is the "specialized
>> packaging" you referred to?
>>
>>
>> On Fri, Apr 26, 2013 at 12:32 PM, David Medinets
>> <[EMAIL PROTECTED]>wrote:
>>
>> > Does it make sense to put vendor-specific stuff under a contribs/vendors
>> > directory? Doing so would certainly indicate that we are vendor-agnostic.
>> > And give vendors an obvious place to contribute.
>> >
>>
+
Josh Elser 2013-04-30, 04:01
+
John Vines 2013-04-30, 04:32
+
John Vines 2013-05-07, 15:10
+
Christopher 2013-05-07, 15:23
+
John Vines 2013-05-07, 15:28
+
David Medinets 2013-05-07, 16:38
+
Christopher 2013-04-25, 19:11