This is an automatically generated e-mail. To reply, visit:
A few style nits and suggestions below, other than that at a high level I think you should split this into two patches so it's easy to review: One should make the keepFields thing keep the priority (this is basically a bug-fix), the 2nd patch should extend this functionality to Multiport and UDP as you are also doing here.

    style: we always use braces on an else


    baosRaw is not a descriptive name. Also, this is not a ByteArrayOutputStream. If this variable really is required, consider using a variable name like rawSyslogLine or something like that.


    style: if your "if" statement has a line-break always use curly braces
    Also, this would be easier to read if you did it like:
    if (!keepFields) {
      if (msgBody != null) && msgBody.length() > 0) {
        body = msgBody.getBytes();
      } else {
        // Parse failed.
        body = baos.toByteArray();
    } else {
      body = baosRaw; // Change this variable name though


    Is this baosRaw thing required? Could we somehow just use baos instead? I am not sure, just an idea.


    Doesn't look like this import is used.


    style: Don't reorder these includes, it's just noisy and my editor might not agree with yours so nobody is "right". Just keep with the existing pattern in the file.


    style: indent this 4 spaces
- Mike Percy
On Nov. 1, 2013, 2:20 p.m., Jeff jlord wrote:
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB