Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive, mail # user - Is there a metastore schema script for postgresql for Hive version 0.9.0


Copy link to this message
-
Re: Is there a metastore schema script for postgresql for Hive version 0.9.0
Carl Steinbach 2012-05-13, 02:30
Hi Xiabo,

Upgrade/schema scripts for Postgres were committed to trunk last week in
HIVE-2529 (https://issues.apache.org/jira/browse/HIVE-2529). This patch
includes schema DDL for Hive 0.8.0 and 0.9.0, as well as an 0.7.0->0.8.0
upgrade script. Right now these scripts are only available in the source
code repository.

Thanks.

Carl

On Sat, May 12, 2012 at 12:58 PM, Ashutosh Chauhan <[EMAIL PROTECTED]>wrote:

> Hi Xiaobo,
>
> It depends on what your current setup is:
> a) If you are trying Hive for the first time, then you don't necessarily
> need to create schema in postgres upfront. As wd suggested, datanucleus
> (ORM used by Hive) can autocreate the schema if it doesn't exist.
> b) If you are already using Hive 0.8 then there is no upgrade step, there
> are no metastore schema changes between 0.8 & 0.9, so your existing Hive
> 0.8 postgres will continue to work with Hive 0.9
> c) If you are currently using Hive 0.7 or earlier, then you do need to
> migrate. Unfortunately, with Hive 0.8 we didn't publish upgrade script for
> 0.7 to 0.8. But, good news is support for Postgres is reinstated in trunk.
> You can find Postgres upgrade scripts here:
> http://svn.apache.org/repos/asf/hive/trunk/metastore/scripts/upgrade/postgres/
>
> Hope it helps,
> Ashutosh
>
>
> On Fri, May 11, 2012 at 11:28 PM, Xiaobo Gu <[EMAIL PROTECTED]>wrote:
>
>> **
>> I can't find it in the release package.
>>
>> ------------------------------
>> Xiaobo Gu
>>
>
>