Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop >> mail # dev >> Review Request: SQOOP-600: HBase table family presence is not working correctly on new HBase versions


Copy link to this message
-
Re: Review Request: SQOOP-600: HBase table family presence is not working correctly on new HBase versions

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/7014/#review11429
-----------------------------------------------------------
ant test (100): Success. I think the Hbase tests are disabled for hadoopversion 100 as well. Let me know.
ant test (20): Hbase tests timed out for me(TestHbaseImport and TestHbaseQueryImport). These don't seem to be a regression as they are failing on my m/c for current trunk as well. If they work for you, I have a ship it.

- Abhijeet Gaikwad
On Sept. 11, 2012, 11:03 a.m., Jarek Cecho wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/7014/
> -----------------------------------------------------------
>
> (Updated Sept. 11, 2012, 11:03 a.m.)
>
>
> Review request for Sqoop.
>
>
> Description
> -------
>
> Problem is that we're creating Table descriptor locally, which is not importing remote table families automatically. I've enhanced the code to retrieve remote table descriptor prior checking if the table family is present.
>
>
> This addresses bug SQOOP-600.
>     https://issues.apache.org/jira/browse/SQOOP-600
>
>
> Diffs
> -----
>
>   src/java/org/apache/sqoop/mapreduce/HBaseImportJob.java 6a784d2
>
> Diff: https://reviews.apache.org/r/7014/diff/
>
>
> Testing
> -------
>
> I've done only manual testing on HBase 0.94. Automatic tests are disabled in different profiles other than hadoopversion={20,100} and I'll work on getting them working later.
>
>
> Thanks,
>
> Jarek Cecho
>
>